p PatchFirst

CVE-2021-32808

CVE-2021-32808 · Cross-site scripting in ckeditor via abuse of undo functionality

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

CVSS 7.6 · Высокий · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • ckeditor4

    Версии
    • >= 4.13.0, < 4.16.2: Затронуто

    Нет опубликованного исправления

  • ckeditor Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.16.2+dfsg-1

    Обновитесь до 4.16.2+dfsg-1

  • ckeditor4 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.13.0, < 4.16.2

    Обновитесь до 4.16.2

Первоисточники

Проверьте свой сервер →