p PatchFirst

CVE-2021-32839

CVE-2021-32839 · Regular Expression Denial of Service in sqlparse

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

sqlparse is a non-validating SQL parser module for Python. In sqlparse versions 0.4.0 and 0.4.1 there is a regular Expression Denial of Service in sqlparse vulnerability. The regular expression may cause exponential backtracking on strings containing many repetitions of '\r\n' in SQL comments. Only the formatting feature that removes comments from SQL statements is affected by this regular expression. As a workaround don't use the sqlformat.format function with keyword strip_comments=True or the --strip-comments command line flag when using the sqlformat command line tool. The issues has been fixed in sqlparse 0.4.2.

CVSS 7.5 · Высокий · EPSS 2,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • sqlparse

    Версии
    • >= 0.4.0, < 0.4.2: Затронуто

    Нет опубликованного исправления

  • sqlparse Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.4.2-1

    Обновитесь до 0.4.2-1

  • sqlparse Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.4.2-1

    Обновитесь до 0.4.2-1

  • sqlparse Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.4.2-1

    Обновитесь до 0.4.2-1

  • sqlparse PyPI

    Версии
    • 0.4.0
    • 0.4.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 0.4.0, < 0.4.2

    Обновитесь до 0.4.2

  • sqlparse PyPI

    Версии
    • 0.4.0
    • 0.4.1
    Затронутые диапазоны версий
    • GIT: ≥ 1499cffcd7c4d635b4297b44d48fb4fe94cf988e, < 8238a9e450ed1524e40cb3a8b0b3c00606903aeb
    • ECOSYSTEM: ≥ 0.4.0, < 0.4.2

    Обновитесь до 0.4.2

  • sqlparse Ubuntu:22.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.4.1-1ubuntu1

    Обновитесь до 0.4.1-1ubuntu1

Первоисточники

Проверьте свой сервер →