p PatchFirst

CVE-2021-33560

CVE-2021-33560

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

CVSS 7.5 · Высокий · EPSS 2,4% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • libgcrypt20 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.9.4-2

    Обновитесь до 1.9.4-2

  • libgcrypt20 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.9.4-2

    Обновитесь до 1.9.4-2

  • libgcrypt20 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.9.4-2

    Обновитесь до 1.9.4-2

  • libgcrypt20 Ubuntu:Pro:16.04:LTS

    Версии
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    • 1.6.5-2ubuntu0.2
    • 1.6.5-2ubuntu0.3
    • 1.6.5-2ubuntu0.4
    • 1.6.5-2ubuntu0.5
    • 1.6.5-2ubuntu0.6
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.5-2ubuntu0.6+esm1

    Обновитесь до 1.6.5-2ubuntu0.6+esm1

  • libgcrypt20 Ubuntu:18.04:LTS

    Версии
    • 1.7.8-2ubuntu1
    • 1.7.9-1
    • 1.8.1-4
    • 1.8.1-4ubuntu1
    • 1.8.1-4ubuntu1.1
    • 1.8.1-4ubuntu1.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.8.1-4ubuntu1.3

    Обновитесь до 1.8.1-4ubuntu1.3

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS

    Версии
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.8.1-4ubuntu1.fips.3

    Обновитесь до 1.8.1-4ubuntu1.fips.3

  • libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS

    Версии
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • libgcrypt20 Ubuntu:20.04:LTS

    Версии
    • 1.8.4-5ubuntu2
    • 1.8.5-3ubuntu1
    • 1.8.5-5ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.8.5-5ubuntu1.1

    Обновитесь до 1.8.5-5ubuntu1.1

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1

    Обновитесь до 1.8.5-5ubuntu1.fips.1.1

  • libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1

    Обновитесь до 1.8.5-5ubuntu1.fips.1.1

  • libgcrypt20 Ubuntu:22.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.8.7-5ubuntu2

    Обновитесь до 1.8.7-5ubuntu2

Первоисточники

Проверьте свой сервер →