p PatchFirst

CVE-2021-3449

CVE-2021-3449 · NULL pointer deref in signature_algorithms processing

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.

An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client. If a TLSv1.2 renegotiation ClientHello omits the signature_algorithms extension (where it was present in the initial ClientHello), but includes a signature_algorithms_cert extension then a NULL pointer dereference will result, leading to a crash and a denial of service attack. A server is only vulnerable if it has TLSv1.2 and renegotiation enabled (which is the default configuration). OpenSSL TLS clients are not impacted by this issue. All OpenSSL 1.1.1 versions are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j).

CVSS 5.9 · Средний · EPSS 63,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · network

Затронутые продукты и версии

  • openssl

    Версии
    • Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j): Затронуто

    Нет опубликованного исправления

  • openssl Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1k-1

    Обновитесь до 1.1.1k-1

  • openssl Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1k-1

    Обновитесь до 1.1.1k-1

  • openssl Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1k-1

    Обновитесь до 1.1.1k-1

  • openssl Ubuntu:18.04:LTS

    Версии
    • 1.0.2g-1ubuntu13
    • 1.0.2g-1ubuntu14
    • 1.0.2n-1ubuntu1
    • 1.1.0g-2ubuntu1
    • 1.1.0g-2ubuntu2
    • 1.1.0g-2ubuntu3
    • 1.1.0g-2ubuntu4
    • 1.1.0g-2ubuntu4.1
    • 1.1.0g-2ubuntu4.3
    • 1.1.1-1ubuntu2.1~18.04.1
    • 1.1.1-1ubuntu2.1~18.04.2
    • 1.1.1-1ubuntu2.1~18.04.3
    • 1.1.1-1ubuntu2.1~18.04.4
    • 1.1.1-1ubuntu2.1~18.04.5
    • 1.1.1-1ubuntu2.1~18.04.6
    • 1.1.1-1ubuntu2.1~18.04.7
    • 1.1.1-1ubuntu2.1~18.04.8
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1-1ubuntu2.1~18.04.9

    Обновитесь до 1.1.1-1ubuntu2.1~18.04.9

  • postgresql-10 Ubuntu:18.04:LTS

    Версии
    • 10.1-1
    • 10.1-2
    • 10.2-1
    • 10.3-1
    • 10.4-0ubuntu0.18.04
    • 10.5-0ubuntu0.18.04
    • 10.6-0ubuntu0.18.04.1
    • 10.7-0ubuntu0.18.04.1
    • 10.8-0ubuntu0.18.04.1
    • 10.9-0ubuntu0.18.04.1
    • 10.10-0ubuntu0.18.04.1
    • 10.12-0ubuntu0.18.04.1
    • 10.14-0ubuntu0.18.04.1
    • 10.15-0ubuntu0.18.04.1
    • 10.16-0ubuntu0.18.04.1
    • 10.17-0ubuntu0.18.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.18-0ubuntu0.18.04.1

    Обновитесь до 10.18-0ubuntu0.18.04.1

  • openssl Ubuntu:Pro:FIPS-updates:18.04:LTS

    Версии
    • 1.1.1-1ubuntu2.fips.2.1~18.04.5.1
    • 1.1.1-1ubuntu2.fips.2.1~18.04.6.1
    • 1.1.1-1ubuntu2.fips.2.1~18.04.7.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1-1ubuntu2.fips.2.1~18.04.9.1

    Обновитесь до 1.1.1-1ubuntu2.fips.2.1~18.04.9.1

  • openssl Ubuntu:Pro:FIPS:18.04:LTS

    Версии
    • 1.1.1-1ubuntu2.fips.2.1~18.04.3.1
    • 1.1.1-1ubuntu2.fips.2.1~18.04.15.2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • openssl Ubuntu:20.04:LTS

    Версии
    • 1.1.1c-1ubuntu4
    • 1.1.1d-2ubuntu3
    • 1.1.1d-2ubuntu6
    • 1.1.1f-1ubuntu1
    • 1.1.1f-1ubuntu2
    • 1.1.1f-1ubuntu2.1
    • 1.1.1f-1ubuntu2.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1f-1ubuntu2.3

    Обновитесь до 1.1.1f-1ubuntu2.3

  • postgresql-12 Ubuntu:20.04:LTS

    Версии
    • 12.0-1
    • 12.1-1
    • 12.1-2build1
    • 12.2-1
    • 12.2-1ubuntu2
    • 12.2-4
    • 12.4-0ubuntu0.20.04.1
    • 12.5-0ubuntu0.20.04.1
    • 12.6-0ubuntu0.20.04.1
    • 12.7-0ubuntu0.20.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 12.8-0ubuntu0.20.04.1

    Обновитесь до 12.8-0ubuntu0.20.04.1

  • openssl Ubuntu:Pro:FIPS-updates:20.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1f-1ubuntu2.fips.7

    Обновитесь до 1.1.1f-1ubuntu2.fips.7

  • openssl Ubuntu:Pro:FIPS:20.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.1.1f-1ubuntu2.fips.2.8

    Обновитесь до 1.1.1f-1ubuntu2.fips.2.8

Первоисточники

Проверьте свой сервер →