p PatchFirst

CVE-2021-35940

CVE-2021-35940 · Regression of CVE-2017-12613

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

CVSS 7.1 · Высокий · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache portable runtime (apr)

    Версии
    • Apache Portable Runtime 1.7.0: Затронуто

    Нет опубликованного исправления

  • apr Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.7.0-7

    Обновитесь до 1.7.0-7

  • apr Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.7.0-7

    Обновитесь до 1.7.0-7

  • apr Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.7.0-7

    Обновитесь до 1.7.0-7

  • apr Ubuntu:Pro:14.04:LTS

    Версии
    • 1.4.8-1ubuntu1
    • 1.4.8-2
    • 1.4.8-3
    • 1.5.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.5.0-1ubuntu0.1~esm1

    Обновитесь до 1.5.0-1ubuntu0.1~esm1

  • apr Ubuntu:Pro:16.04:LTS

    Версии
    • 1.5.2-3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.5.2-3ubuntu0.1~esm1

    Обновитесь до 1.5.2-3ubuntu0.1~esm1

  • apr Ubuntu:22.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.7.0-6ubuntu1

    Обновитесь до 1.7.0-6ubuntu1

Первоисточники

Проверьте свой сервер →