p PatchFirst

CVE-2021-37616

CVE-2021-37616 · Null pointer dereference in Exiv2::Internal::resolveLens0x8ff

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. A null pointer dereference was found in Exiv2 versions v0.27.4 and earlier. The null pointer dereference is triggered when Exiv2 is used to print the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. Note that this bug is only triggered when printing the interpreted (translated) data, which is a less frequently used Exiv2 operation that requires an extra command line option (`-p t` or `-P t`). The bug is fixed in version v0.27.5.

CVSS 5.5 · Средний · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • exiv2

    Версии
    • <= 0.27.4: Затронуто

    Нет опубликованного исправления

  • exiv2 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.27.5-1

    Обновитесь до 0.27.5-1

  • exiv2 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.27.5-1

    Обновитесь до 0.27.5-1

  • exiv2 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.27.5-1

    Обновитесь до 0.27.5-1

  • exiv2 Ubuntu:Pro:16.04:LTS

    Версии
    • 0.25-1ubuntu1
    • 0.25-2.1
    • 0.25-2.1ubuntu16.04.1
    • 0.25-2.1ubuntu16.04.2
    • 0.25-2.1ubuntu16.04.3
    • 0.25-2.1ubuntu16.04.4
    • 0.25-2.1ubuntu16.04.5
    • 0.25-2.1ubuntu16.04.6
    • 0.25-2.1ubuntu16.04.7+esm1
    • 0.25-2.1ubuntu16.04.7+esm2
    • 0.25-2.1ubuntu16.04.7+esm3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4

    Обновитесь до 0.25-2.1ubuntu16.04.7+esm4

  • exiv2 Ubuntu:20.04:LTS

    Версии
    • 0.25-4ubuntu2
    • 0.25-4ubuntu3
    • 0.27.2-8ubuntu2
    • 0.27.2-8ubuntu2.2
    • 0.27.2-8ubuntu2.4
    • 0.27.2-8ubuntu2.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.27.2-8ubuntu2.6

    Обновитесь до 0.27.2-8ubuntu2.6

  • exiv2 Ubuntu:22.04:LTS

    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.27.3-3ubuntu4

    Обновитесь до 0.27.3-3ubuntu4

Первоисточники

Проверьте свой сервер →