p PatchFirst

CVE-2021-39134

CVE-2021-39134 · UNIX Symbolic Link (Symlink) Following in @npmcli/arborist

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

`@npmcli/arborist`, the library that calculates dependency trees and manages the `node_modules` folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the extraction of package contents will always be performed into the expected folder. This is, in part, accomplished by resolving dependency specifiers defined in `package.json` manifests for dependencies with a specific name, and nesting folders to resolve conflicting dependencies. When multiple dependencies differ only in the case of their name, Arborist's internal data structure saw them as separate items that could coexist within the same level in the `node_modules` hierarchy. However, on case-insensitive file systems (such as macOS and Windows), this is not the case. Combined with a symlink dependency such as `file:/some/path`, this allowed an attacker to create a situation in which arbitrary contents could be written to any location on the filesystem. For example, a package `pwn-a` could define a dependency in their `package.json` file such as `"foo": "file:/some/path"`. Another package, `pwn-b` could define a dependency such as `FOO: "file:foo.tgz"`. On case-insensitive file systems, if `pwn-a` was installed, and then `pwn-b` was installed afterwards, the contents of `foo.tgz` would be written to `/some/path`, and any existing contents of `/some/path` would be removed. Anyone using npm v7.20.6 or earlier on a case-insensitive filesystem is potentially affected. This is patched in @npmcli/arborist 2.8.2 which is included in npm v7.20.7 and above.

CVSS 8.2 · Высокий · EPSS 0,6% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • arborist

    Версии
    • < 2.8.2: Затронуто

    Нет опубликованного исправления

  • npm Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.24.0+ds-2

    Обновитесь до 7.24.0+ds-2

  • npm Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.24.0+ds-2

    Обновитесь до 7.24.0+ds-2

  • npm Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.24.0+ds-2

    Обновитесь до 7.24.0+ds-2

  • @npmcli/arborist npm

    Затронутые диапазоны версий
    • SEMVER: < 2.8.2

    Обновитесь до 2.8.2

  • npm Ubuntu:14.04:LTS

    Версии
    • 1.2.18~dfsg-3
    • 1.3.10~dfsg-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • npm Ubuntu:Pro:16.04:LTS

    Версии
    • 1.4.21+ds-2
    • 3.5.2-0ubuntu4
    • 3.5.2-0ubuntu4.1.16.04.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • npm Ubuntu:Pro:18.04:LTS

    Версии
    • 3.5.2-0ubuntu4
    • 3.5.2-0ubuntu4.1.18.04.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • npm Ubuntu:20.04:LTS

    Версии
    • 5.8.0+ds6-4
    • 6.14.4+ds-1ubuntu2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →