p PatchFirst

CVE-2021-39192

CVE-2021-39192 · Privilege escalation: all users can access Admin-level API keys

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.

CVSS 6.5 · Средний · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • ghost

    Версии
    • >= 4.0.0, < 4.10.0: Затронуто

    Нет опубликованного исправления

  • ghost npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.10.0

    Обновитесь до 4.10.0

Первоисточники

Проверьте свой сервер →