p PatchFirst

CVE-2021-3975

CVE-2021-3975

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A use-after-free flaw was found in libvirt. The qemuMonitorUnregister() function in qemuProcessHandleMonitorEOF is called using multiple threads without being adequately protected by a monitor lock. This flaw could be triggered by the virConnectGetAllDomainStats API when the guest is shutting down. An unprivileged client with a read-only connection could use this flaw to perform a denial of service attack by causing the libvirt daemon to crash.

CVSS 6.5 · Средний · EPSS 1,6% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • libvirt

    Версии
    • Fixed in libvirt v7.1.0: Затронуто

    Нет опубликованного исправления

  • libvirt Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.6.0-1

    Обновитесь до 7.6.0-1

  • libvirt Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.6.0-1

    Обновитесь до 7.6.0-1

  • libvirt Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.6.0-1

    Обновитесь до 7.6.0-1

  • libvirt Ubuntu:18.04:LTS

    Версии
    • 3.6.0-1ubuntu5
    • 3.6.0-1ubuntu6
    • 4.0.0-1ubuntu1
    • 4.0.0-1ubuntu2
    • 4.0.0-1ubuntu3
    • 4.0.0-1ubuntu4
    • 4.0.0-1ubuntu5
    • 4.0.0-1ubuntu6
    • 4.0.0-1ubuntu7
    • 4.0.0-1ubuntu8
    • 4.0.0-1ubuntu8.1
    • 4.0.0-1ubuntu8.2
    • 4.0.0-1ubuntu8.3
    • 4.0.0-1ubuntu8.4
    • 4.0.0-1ubuntu8.5
    • 4.0.0-1ubuntu8.6
    • 4.0.0-1ubuntu8.7
    • 4.0.0-1ubuntu8.8
    • 4.0.0-1ubuntu8.9
    • 4.0.0-1ubuntu8.10
    • 4.0.0-1ubuntu8.11
    • 4.0.0-1ubuntu8.12
    • 4.0.0-1ubuntu8.13
    • 4.0.0-1ubuntu8.14
    • 4.0.0-1ubuntu8.15
    • 4.0.0-1ubuntu8.16
    • 4.0.0-1ubuntu8.17
    • 4.0.0-1ubuntu8.19
    • 4.0.0-1ubuntu8.20
    Затронутые диапазоны версий
    • ECOSYSTEM: < 4.0.0-1ubuntu8.21

    Обновитесь до 4.0.0-1ubuntu8.21

  • libvirt Ubuntu:20.04:LTS

    Версии
    • 5.4.0-0ubuntu5
    • 6.0.0-0ubuntu1
    • 6.0.0-0ubuntu2
    • 6.0.0-0ubuntu3
    • 6.0.0-0ubuntu4
    • 6.0.0-0ubuntu5
    • 6.0.0-0ubuntu6
    • 6.0.0-0ubuntu7
    • 6.0.0-0ubuntu8
    • 6.0.0-0ubuntu8.1
    • 6.0.0-0ubuntu8.2
    • 6.0.0-0ubuntu8.3
    • 6.0.0-0ubuntu8.4
    • 6.0.0-0ubuntu8.5
    • 6.0.0-0ubuntu8.7
    • 6.0.0-0ubuntu8.8
    • 6.0.0-0ubuntu8.9
    • 6.0.0-0ubuntu8.10
    • 6.0.0-0ubuntu8.11
    • 6.0.0-0ubuntu8.12
    • 6.0.0-0ubuntu8.13
    • 6.0.0-0ubuntu8.14
    • 6.0.0-0ubuntu8.15
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.0.0-0ubuntu8.16

    Обновитесь до 6.0.0-0ubuntu8.16

  • libvirt Ubuntu:22.04:LTS

    Версии
    • 7.6.0-0ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 7.6.0-0ubuntu3

    Обновитесь до 7.6.0-0ubuntu3

Первоисточники

Проверьте свой сервер →