CVE-2021-41092
CVE-2021-41092 · Docker CLI leaks private registry credentials to registry-1.docker.io
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Docker CLI is the command line interface for the docker container runtime. A bug was found in the Docker CLI where running `docker login my-private-registry.example.com` with a misconfigured configuration file (typically `~/.docker/config.json`) listing a `credsStore` or `credHelpers` that could not be executed would result in any provided credentials being sent to `registry-1.docker.io` rather than the intended private registry. This bug has been fixed in Docker CLI 20.10.9. Users should update to this version as soon as possible. For users unable to update ensure that any configured credsStore or credHelpers entries in the configuration file reference an installed credential helper that is executable and on the PATH.
CVSS 5.4 · Средний · EPSS 1,7% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
cli
- Версии
- < 20.10.9: Затронуто
Нет опубликованного исправления
docker.io Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 20.10.10+dfsg1-1
Обновитесь до 20.10.10+dfsg1-1
docker.io Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 20.10.10+dfsg1-1
Обновитесь до 20.10.10+dfsg1-1
docker.io Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 20.10.10+dfsg1-1
Обновитесь до 20.10.10+dfsg1-1
docker.io Ubuntu:Pro:16.04:LTS
- Версии
- 1.6.2~dfsg1-1ubuntu4
- 1.10.2-0ubuntu3
- 1.10.2-0ubuntu4
- 1.10.3-0ubuntu1
- 1.10.3-0ubuntu4
- 1.10.3-0ubuntu5
- 1.10.3-0ubuntu6
- 1.11.2-0ubuntu5~16.04
- 1.12.1-0ubuntu13~16.04.1
- 1.12.3-0ubuntu4~16.04.2
- 1.12.6-0ubuntu1~16.04.1
- 1.13.1-0ubuntu1~16.04.2
- 17.03.2-0ubuntu2~16.04.1
- 18.06.1-0ubuntu1~16.04.2
- 18.06.1-0ubuntu1.2~16.04.1
- 18.09.2-0ubuntu1~16.04.1
- 18.09.5-0ubuntu1~16.04.2
- 18.09.7-0ubuntu1~16.04.1
- 18.09.7-0ubuntu1~16.04.4
- 18.09.7-0ubuntu1~16.04.5
- 18.09.7-0ubuntu1~16.04.6
- 18.09.7-0ubuntu1~16.04.7
- 18.09.7-0ubuntu1~16.04.9+esm1
- 18.09.7-0ubuntu1~16.04.9+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
docker.io Ubuntu:18.04:LTS
- Версии
- 1.13.1-0ubuntu6
- 17.03.2-0ubuntu1
- 17.03.2-0ubuntu3
- 17.03.2-0ubuntu5
- 17.12.1-0ubuntu1
- 18.06.1-0ubuntu1~18.04.1
- 18.06.1-0ubuntu1.2~18.04.1
- 18.09.2-0ubuntu1~18.04.1
- 18.09.5-0ubuntu1~18.04.2
- 18.09.7-0ubuntu1~18.04.1
- 18.09.7-0ubuntu1~18.04.3
- 18.09.7-0ubuntu1~18.04.4
- 19.03.6-0ubuntu1~18.04.1
- 19.03.6-0ubuntu1~18.04.2
- 19.03.6-0ubuntu1~18.04.3
- 20.10.2-0ubuntu1~18.04.2
- 20.10.2-0ubuntu1~18.04.3
- 20.10.7-0ubuntu1~18.04.1
- 20.10.7-0ubuntu1~18.04.2
- 20.10.7-0ubuntu5~18.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 20.10.7-0ubuntu5~18.04.3
Обновитесь до 20.10.7-0ubuntu5~18.04.3
docker.io Ubuntu:20.04:LTS
- Версии
- 19.03.2-0ubuntu1
- 19.03.6-0ubuntu1
- 19.03.8-0ubuntu1
- 19.03.8-0ubuntu1.20.04
- 19.03.8-0ubuntu1.20.04.1
- 19.03.8-0ubuntu1.20.04.2
- 20.10.2-0ubuntu1~20.04.2
- 20.10.2-0ubuntu1~20.04.3
- 20.10.7-0ubuntu1~20.04.1
- 20.10.7-0ubuntu1~20.04.2
- 20.10.7-0ubuntu5~20.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 20.10.7-0ubuntu5~20.04.2
Обновитесь до 20.10.7-0ubuntu5~20.04.2
docker.io Ubuntu:22.04:LTS
- Версии
- 20.10.7-0ubuntu5
- Затронутые диапазоны версий
- ECOSYSTEM: < 20.10.7-0ubuntu7
Обновитесь до 20.10.7-0ubuntu7
Первоисточники
- https://github.com/docker/cli/security/advisories/GHSA-99pg-grm5-qq3v
- https://github.com/docker/cli/commit/893e52cf4ba4b048d72e99748e0f86b2767c6c6b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/
- https://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41092