CVE-2021-41099
CVE-2021-41099 · Integer overflow issue with strings in Redis
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Redis is an open source, in-memory database that persists on disk. An integer overflow bug in the underlying string library can be used to corrupt the heap and potentially result with denial of service or remote code execution. The vulnerability involves changing the default proto-max-bulk-len configuration parameter to a very large value and constructing specially crafted network payloads or commands. The problem is fixed in Redis versions 6.2.6, 6.0.16 and 5.0.14. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from modifying the proto-max-bulk-len configuration parameter. This can be done using ACL to restrict unprivileged users from using the CONFIG SET command.
CVSS 7.5 · Высокий · EPSS 3,6% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
redis
- Версии
- < 5.0.14: Затронуто
- >= 6.0.0, < 6.0.16: Затронуто
- >= 6.2.0, 6.2.6: Затронуто
Нет опубликованного исправления
redis Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:6.0.16-1
Обновитесь до 5:6.0.16-1
redis Ubuntu:Pro:18.04:LTS
- Версии
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm3
Обновитесь до 5:4.0.9-1ubuntu0.2+esm3
redis Ubuntu:Pro:20.04:LTS
- Версии
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm1
Обновитесь до 5:5.0.7-2ubuntu0.1+esm1
Первоисточники
- https://github.com/redis/redis/security/advisories/GHSA-j3cr-9h5g-6cph
- https://github.com/redis/redis/commit/c6ad876774f3cc11e32681ea02a2eead00f2c521
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VL5KXFN3ATM7IIM7Q4O4PWTSRGZ5744Z/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HTYQ5ZF37HNGTZWVNJD3VXP7I6MEEF42/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WR5WKJWXD4D6S3DJCZ56V74ESLTDQRAB/
- https://www.debian.org/security/2021/dsa-5001
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://security.netapp.com/advisory/ntap-20211104-0003/
- https://security.gentoo.org/glsa/202209-17
- https://nvd.nist.gov/vuln/detail/CVE-2021-41099