CVE-2021-41103
CVE-2021-41103 · Insufficiently restricted permissions on plugin directories
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.
CVSS 5.9 · Средний · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: system · containers
Затронутые продукты и версии
containerd
- Версии
- < 1.4.11: Затронуто
- >= 1.5.0, < 1.5.7: Затронуто
Нет опубликованного исправления
containerd Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.7~ds1-1
Обновитесь до 1.5.7~ds1-1
containerd Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.7~ds1-1
Обновитесь до 1.5.7~ds1-1
containerd Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.7~ds1-1
Обновитесь до 1.5.7~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Версии
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm2
Обновитесь до 1.2.6-0ubuntu1~16.04.6+esm2
containerd Ubuntu:18.04:LTS
- Версии
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.2-0ubuntu1~18.04.3
Обновитесь до 1.5.2-0ubuntu1~18.04.3
containerd Ubuntu:20.04:LTS
- Версии
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.2-0ubuntu1~20.04.3
Обновитесь до 1.5.2-0ubuntu1~20.04.3
containerd Ubuntu:22.04:LTS
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.5-0ubuntu3
Обновитесь до 1.5.5-0ubuntu3
Первоисточники
- https://github.com/containerd/containerd/security/advisories/GHSA-c2h3-6mxw-7mvq
- https://github.com/containerd/containerd/commit/5b46e404f6b9f661a205e28d59c982d3634148f8
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/
- https://www.debian.org/security/2021/dsa-5002
- https://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdf
- https://security.gentoo.org/glsa/202401-31
- https://nvd.nist.gov/vuln/detail/CVE-2021-41103