CVE-2021-41990
CVE-2021-41990
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The gmp plugin in strongSwan before 5.9.4 has a remote integer overflow via a crafted certificate with an RSASSA-PSS signature. For example, this can be triggered by an unrelated self-signed CA certificate sent by an initiator. Remote code execution cannot occur.
CVSS 7.5 · Высокий · EPSS 7,0% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
n/a
- Версии
- n/a: Затронуто
Нет опубликованного исправления
strongswan Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.4-1
Обновитесь до 5.9.4-1
strongswan Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.4-1
Обновитесь до 5.9.4-1
strongswan Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.4-1
Обновитесь до 5.9.4-1
strongswan Ubuntu:18.04:LTS
- Версии
- 5.5.1-4ubuntu2
- 5.5.1-4ubuntu3
- 5.6.1-2ubuntu1
- 5.6.1-2ubuntu2
- 5.6.1-2ubuntu3
- 5.6.1-2ubuntu4
- 5.6.2-1ubuntu2
- 5.6.2-1ubuntu2.2
- 5.6.2-1ubuntu2.3
- 5.6.2-1ubuntu2.4
- 5.6.2-1ubuntu2.5
- 5.6.2-1ubuntu2.6
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.6.2-1ubuntu2.7
Обновитесь до 5.6.2-1ubuntu2.7
strongswan Ubuntu:Pro:FIPS-updates:18.04:LTS
- Версии
- 5.6.2-1ubuntu2.fips.2.5.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.6.2-1ubuntu2.fips.2.7.1
Обновитесь до 5.6.2-1ubuntu2.fips.2.7.1
strongswan Ubuntu:Pro:FIPS:18.04:LTS
- Версии
- 5.6.2-1ubuntu2.fips.2.4.2
- 5.6.2-1ubuntu2.fips.2.5.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:20.04:LTS
- Версии
- 5.7.2-1ubuntu3
- 5.8.1-1ubuntu1
- 5.8.2-1ubuntu1
- 5.8.2-1ubuntu2
- 5.8.2-1ubuntu3
- 5.8.2-1ubuntu3.1
- 5.8.2-1ubuntu3.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.8.2-1ubuntu3.3
Обновитесь до 5.8.2-1ubuntu3.3
strongswan Ubuntu:Pro:FIPS-updates:20.04:LTS
- Версии
- 5.8.2-1ubuntu3.fips.3.1.2
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.8.2-1ubuntu3.fips.3.3.1
Обновитесь до 5.8.2-1ubuntu3.fips.3.3.1
strongswan Ubuntu:Pro:FIPS:20.04:LTS
- Версии
- 5.8.2-1ubuntu3.fips.3.1.2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
strongswan Ubuntu:22.04:LTS
- Версии
- 5.9.1-1ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: < 5.9.1-1ubuntu3.1
Обновитесь до 5.9.1-1ubuntu3.1
Первоисточники
- https://github.com/strongswan/strongswan/releases/tag/5.9.4
- https://www.strongswan.org/blog/2021/10/18/strongswan-vulnerability-%28cve-2021-41990%29.html
- https://www.debian.org/security/2021/dsa-4989
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5FJSATD2R2XHTG4P63GCMQ2N7EWKMME5/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WQSQ3BEC22NF4NCDZVCT4P3Q2ZIAJXGJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Y3TQ32JLJOBJDB2EJKSX2PBPB5NFG2D4/
- https://cert-portal.siemens.com/productcert/pdf/ssa-539476.pdf
- https://nvd.nist.gov/vuln/detail/CVE-2021-41990