p PatchFirst

CVE-2021-4231

CVE-2021-4231 · Angular Comment cross site scripting

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.

CVSS 3.5 · Низкий · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • angular

    Версии
    • 11.0.0: Затронуто
    • 11.0.1: Затронуто
    • 11.0.2: Затронуто
    • 11.0.3: Затронуто
    • 11.0.4: Затронуто
    • 11.1.0-next.0: Затронуто
    • 11.1.0-next.1: Затронуто
    • 11.1.0-next.2: Затронуто

    Нет опубликованного исправления

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 11.0.0, < 11.0.5

    Обновитесь до 11.0.5

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 11.1.0-next.0, < 11.1.0-next.3

    Обновитесь до 11.1.0-next.3

  • @angular/core npm

    Затронутые диапазоны версий
    • SEMVER: < 10.2.5

    Обновитесь до 10.2.5

Первоисточники

Проверьте свой сервер →