p PatchFirst

CVE-2021-43797

CVE-2021-43797 · HTTP fails to validate against control chars in header names which may lead to HTTP request smuggling

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to version 4.1.71.Final.

CVSS 6.5 · Средний · EPSS 2,9% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • netty

    Версии
    • <= 4.1.7.0.Final: Затронуто

    Нет опубликованного исправления

  • netty Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-6

    Обновитесь до 1:4.1.48-6

  • netty Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-6

    Обновитесь до 1:4.1.48-6

  • netty Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-6

    Обновитесь до 1:4.1.48-6

  • netty Ubuntu:Pro:14.04:LTS

    Версии
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • netty Ubuntu:Pro:16.04:LTS

    Версии
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1

    Обновитесь до 1:4.0.34-1ubuntu0.1~esm1

  • netty Ubuntu:Pro:18.04:LTS

    Версии
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2

    Обновитесь до 1:4.1.7-4ubuntu0.1+esm2

  • netty Ubuntu:Pro:20.04:LTS

    Версии
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1

    Обновитесь до 1:4.1.45-1ubuntu0.1~esm1

  • netty Ubuntu:22.04:LTS

    Версии
    • 1:4.1.48-4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1

    Обновитесь до 1:4.1.48-4+deb11u1build0.22.04.1

Первоисточники

Проверьте свой сервер →