p PatchFirst

CVE-2021-44731

CVE-2021-44731 · snapd could be made to escalate privileges and run programs as administrator

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A race condition existed in the snapd 2.54.2 snap-confine binary when preparing a private mount namespace for a snap. This could allow a local attacker to gain root privileges by bind-mounting their own contents inside the snap's private mount namespace and causing snap-confine to execute arbitrary code and hence gain privilege escalation. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1

CVSS 7.8 · Высокий · EPSS 1,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • snapd

    Версии
    • ≥ unspecified, ≤ 2.54.2: Затронуто (custom)

    Нет опубликованного исправления

  • snapd Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3-1

    Обновитесь до 2.54.3-1

  • snapd Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3-1

    Обновитесь до 2.54.3-1

  • snapd Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3-1

    Обновитесь до 2.54.3-1

  • snapd Ubuntu:Pro:14.04:LTS

    Версии
    • 2.21~14.04.2
    • 2.22.2~14.04
    • 2.22.3~14.04
    • 2.22.6~14.04
    • 2.23.1~14.04
    • 2.24.1~14.04
    • 2.25~14.04
    • 2.26.10~14.04
    • 2.27.5~14.04
    • 2.28.5~14.04
    • 2.29.4.2~14.04
    • 2.32.3.2~14.04
    • 2.32.9~14.04
    • 2.33.1~14.04
    • 2.34.2~14.04
    • 2.34.2~14.04.1
    • 2.37.4~14.04.1
    • 2.38~14.04
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3+14.04~esm1

    Обновитесь до 2.54.3+14.04~esm1

  • snapd Ubuntu:Pro:16.04:LTS

    Версии
    • 1.9
    • 1.9.1.1
    • 1.9.2
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.5
    • 2.0.8
    • 2.0.9
    • 2.0.10
    • 2.11+0.16.04
    • 2.12+0.16.04
    • 2.13
    • 2.14.2~16.04
    • 2.15.2ubuntu1
    • 2.16ubuntu3
    • 2.17.1ubuntu1
    • 2.20.1ubuntu1
    • 2.21
    • 2.22.2
    • 2.22.3
    • 2.22.6
    • 2.23.1
    • 2.24.1
    • 2.25
    • 2.26.10
    • 2.27.5
    • 2.28.5
    • 2.29.4.2
    • 2.32.3.2
    • 2.32.9
    • 2.33.1ubuntu2
    • 2.34.2
    • 2.34.2ubuntu0.1
    • 2.37.4
    • 2.37.4ubuntu0.1
    • 2.38
    • 2.39.2
    • 2.39.2ubuntu0.2
    • 2.40
    • 2.42.1
    • 2.45.1
    • 2.45.1ubuntu0.2
    • 2.46.1
    • 2.47.1
    • 2.48
    • 2.48.3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3+16.04~esm2

    Обновитесь до 2.54.3+16.04~esm2

  • snapd Ubuntu:18.04:LTS

    Версии
    • 2.28.5+17.10
    • 2.29.4.1+18.04
    • 2.29.4.2+18.04
    • 2.31.1+18.04
    • 2.32+18.04~pre5
    • 2.32+18.04~pre6
    • 2.32+18.04
    • 2.32.3.2+18.04
    • 2.32.5+18.04
    • 2.32.8+18.04
    • 2.32.9+18.04
    • 2.33.1+18.04ubuntu2
    • 2.34.2+18.04
    • 2.34.2+18.04.1
    • 2.37.1+18.04
    • 2.37.1.1+18.04
    • 2.37.4+18.04
    • 2.37.4+18.04.1
    • 2.38+18.04
    • 2.39.2+18.04
    • 2.40+18.04
    • 2.42.1+18.04
    • 2.45.1+18.04
    • 2.45.1+18.04.2
    • 2.46.1+18.04
    • 2.47.1+18.04
    • 2.48+18.04
    • 2.48.3+18.04
    • 2.49.2+18.04
    • 2.51.1+18.04
    • 2.54.2+18.04ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3+18.04

    Обновитесь до 2.54.3+18.04

  • snapd Ubuntu:20.04:LTS

    Версии
    • 2.41+19.10.1
    • 2.42.1+20.04
    • 2.43.3+git1.8109f8
    • 2.44~pre1+20.04
    • 2.44+20.04
    • 2.44.2+20.04
    • 2.44.3+20.04
    • 2.45.1+20.04
    • 2.45.1+20.04.2
    • 2.46.1+20.04
    • 2.47.1+20.04
    • 2.48+20.04
    • 2.48.3+20.04
    • 2.49.2+20.04
    • 2.51.1+20.04ubuntu2
    • 2.54.2+20.04ubuntu2
    • 2.54.3+20.04
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.54.3+20.04.1

    Обновитесь до 2.54.3+20.04.1

Первоисточники

Проверьте свой сервер →