CVE-2022-23648
CVE-2022-23648 · Insecure handling of image volumes in containerd CRI plugin
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
containerd is a container runtime available as a daemon for Linux and Windows. A bug was found in containerd prior to versions 1.6.1, 1.5.10, and 1.14.12 where containers launched through containerd’s CRI implementation on Linux with a specially-crafted image configuration could gain access to read-only copies of arbitrary files and directories on the host. This may bypass any policy-based enforcement on container setup (including a Kubernetes Pod Security Policy) and expose potentially sensitive information. Kubernetes and crictl can both be configured to use containerd’s CRI implementation. This bug has been fixed in containerd 1.6.1, 1.5.10, and 1.4.12. Users should update to these versions to resolve the issue.
CVSS 7.5 · Высокий · EPSS 27,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system · containers
Затронутые продукты и версии
containerd
- Версии
- < 1.4.13: Затронуто
- >= 1.5.0, < 1.5.10: Затронуто
- >= 1.6.0, < 1.6.1: Затронуто
Нет опубликованного исправления
containerd Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1~ds1-1
Обновитесь до 1.6.1~ds1-1
containerd Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1~ds1-1
Обновитесь до 1.6.1~ds1-1
containerd Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1~ds1-1
Обновитесь до 1.6.1~ds1-1
containerd Ubuntu:18.04:LTS
- Версии
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.3
- 1.5.5-0ubuntu3~18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.5-0ubuntu3~18.04.2
Обновитесь до 1.5.5-0ubuntu3~18.04.2
containerd Ubuntu:20.04:LTS
- Версии
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.3
- 1.5.5-0ubuntu3~20.04.1
- 1.5.5-0ubuntu3~20.04.2
- 1.5.9-0ubuntu1~20.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.4
Обновитесь до 1.5.9-0ubuntu1~20.04.4
containerd Ubuntu:22.04:LTS
- Версии
- 1.5.5-0ubuntu3
- 1.5.9-0ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.5.9-0ubuntu2
Обновитесь до 1.5.9-0ubuntu2
Первоисточники
- https://github.com/containerd/containerd/security/advisories/GHSA-crp2-qrr5-8pq7
- https://github.com/containerd/containerd/commit/10f428dac7cec44c864e1b830a4623af27a9fc70
- https://github.com/containerd/containerd/releases/tag/v1.4.13
- https://github.com/containerd/containerd/releases/tag/v1.5.10
- https://github.com/containerd/containerd/releases/tag/v1.6.1
- https://www.debian.org/security/2022/dsa-5091
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OCCARJ6FU4MWBTXHZNMS7NELPDBIX2VO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AUDQUQBZJGBWJPMRVB6QCCCRF7O3O4PA/
- http://packetstormsecurity.com/files/166421/containerd-Image-Volume-Insecure-Handling.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HFTS2EF3S7HNYSNZSEJZIJHPRU7OPUV3/
- https://security.gentoo.org/glsa/202401-31
- https://nvd.nist.gov/vuln/detail/CVE-2022-23648