CVE-2022-24761
CVE-2022-24761 · HTTP Request Smuggling in waitress
CVSS 7.5 · Высокий · EPSS 1,8% · Есть исправление
Затронуты ли вы?
- waitressНет опубликованного исправления
- waitress Debian 12Обновитесь до 2.1.1-1
- waitress Debian 13Обновитесь до 2.1.1-1
- waitress Debian 14Обновитесь до 2.1.1-1
- и ещё 3
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="waitress"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания waitress и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Waitress is a Web Server Gateway Interface server for Python 2 and 3. When using Waitress versions 2.1.0 and prior behind a proxy that does not properly validate the incoming HTTP request matches the RFC7230 standard, Waitress and the frontend proxy may disagree on where one request starts and where it ends. This would allow requests to be smuggled via the front-end proxy to waitress and later behavior. There are two classes of vulnerability that may lead to request smuggling that are addressed by this advisory: The use of Python's `int()` to parse strings into integers, leading to `+10` to be parsed as `10`, or `0x01` to be parsed as `1`, where as the standard specifies that the string should contain only digits or hex digits; and Waitress does not support chunk extensions, however it was discarding them without validating that they did not contain illegal characters. This vulnerability has been patched in Waitress 2.1.1. A workaround is available. When deploying a proxy in front of waitress, turning on any and all functionality to make sure that the request matches the RFC7230 standard. Certain proxy servers may not have this functionality though and users are encouraged to upgrade to the latest version of waitress instead.
- Опубликовано
- Обновлено
Затронутые продукты и версии
waitress
- Версии
- < 2.1.1: Затронуто
Нет опубликованного исправления
waitress Debian 12
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-1
Обновитесь до 2.1.1-1
waitress Debian 13
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-1
Обновитесь до 2.1.1-1
waitress Debian 14
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1-1
Обновитесь до 2.1.1-1
waitress PyPI
- Версии
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
Все версии (47)
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 2.0.0
- 2.0.0b0
- 2.0.0b1
- 2.1.0
- 2.1.0b0
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.1
Обновитесь до 2.1.1
waitress PyPI
- Версии
- 0.1
- 0.2
- 0.3
- 0.4
- 0.5
- 0.6
Все версии (47)
- 0.6.1
- 0.7
- 0.8
- 0.8.1
- 0.8.10
- 0.8.11b0
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 0.8.8
- 0.8.9
- 0.9.0
- 0.9.0b0
- 0.9.0b1
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0a1
- 1.0a2
- 1.1.0
- 1.2.0
- 1.2.0b1
- 1.2.0b2
- 1.2.0b3
- 1.2.1
- 1.3.0
- 1.3.0b0
- 1.3.1
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 2.0.0
- 2.0.0b0
- 2.0.0b1
- 2.1.0
- 2.1.0b0
- Затронутые диапазоны версий
- GIT: < 9e0b8c801e4d505c2ffc91b891af4ba48af715e0
- ECOSYSTEM: < 2.1.1
Обновитесь до 2.1.1
waitress Ubuntu 20.04 LTS
- Версии
- 1.2.0~b2-2
- 1.3.1-4
- 1.4.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.4.1-1ubuntu0.1
Обновитесь до 1.4.1-1ubuntu0.1
waitress Ubuntu 22.04 LTS
- Версии
- 1.4.4-1.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.4.4-1.1ubuntu1
Обновитесь до 1.4.4-1.1ubuntu1
Первоисточники
- https://github.com/Pylons/waitress/security/advisories/GHSA-4f7p-27jc-3c36
- https://github.com/Pylons/waitress/commit/9e0b8c801e4d505c2ffc91b891af4ba48af715e0
- https://github.com/Pylons/waitress/releases/tag/v2.1.1
- https://lists.debian.org/debian-lts-announce/2022/05/msg00011.html
- https://www.debian.org/security/2022/dsa-5138
- https://nvd.nist.gov/vuln/detail/CVE-2022-24761