p PatchFirst

CVE-2022-24858

CVE-2022-24858 · Default redirect callback vulnerable to open redirects

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

next-auth v3 users before version 3.29.2 are impacted. next-auth version 4 users before version 4.3.2 are also impacted. Upgrading to 3.29.2 or 4.3.2 will patch this vulnerability. If you are not able to upgrade for any reason, you can add a configuration to your callbacks option. If you already have a `redirect` callback, make sure that you match the incoming `url` origin against the `baseUrl`.

CVSS 6.1 · Средний · EPSS 0,8% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • next-auth

    Версии
    • < 3.29.2, < 4.3.2: Затронуто

    Нет опубликованного исправления

  • next-auth npm

    Затронутые диапазоны версий
    • SEMVER: < 3.29.2

    Обновитесь до 3.29.2

  • next-auth npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.3.2

    Обновитесь до 4.3.2

Первоисточники

Проверьте свой сервер →