CVE-2022-29244
CVE-2022-29244 · npm packing does not respect root-level ignore files in workspaces
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. `--workspaces`, `--workspace=<name>`). Anyone who has run `npm pack` or `npm publish` inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Users should upgrade to the latest, patched version of npm v8.11.0, run: npm i -g npm@latest . Node.js versions v16.15.1, v17.19.1, and v18.3.0 include the patched v8.11.0 version of npm.
CVSS 7.5 · Высокий · EPSS 4,0% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
npm
- Версии
- ≥ 7.9.0, < 7.9.0*: Затронуто (custom)
- ≥ 8.11.0, < 8.11.0: Затронуто (custom)
Нет опубликованного исправления
npm npm
- Затронутые диапазоны версий
- SEMVER: ≥ 7.9.0, < 8.11.0
Обновитесь до 8.11.0
npm Ubuntu:14.04:LTS
- Версии
- 1.2.18~dfsg-3
- 1.3.10~dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:Pro:16.04:LTS
- Версии
- 1.4.21+ds-2
- 3.5.2-0ubuntu4
- 3.5.2-0ubuntu4.1.16.04.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:Pro:18.04:LTS
- Версии
- 3.5.2-0ubuntu4
- 3.5.2-0ubuntu4.1.18.04.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:20.04:LTS
- Версии
- 5.8.0+ds6-4
- 6.14.4+ds-1ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:22.04:LTS
- Версии
- 7.5.2+ds-2
- 7.24.2+ds-1
- 7.24.2+ds-2
- 8.3.0~ds-1
- 8.3.0~ds-2
- 8.3.2~ds-1
- 8.5.0~ds-1
- 8.5.1~ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:24.04:LTS
- Версии
- 9.2.0~ds1-1
- 9.2.0~ds1-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:25.10
- Версии
- 9.2.0~ds1-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:26.10
- Версии
- 9.2.0~ds3-1
- 11.16.0+ds2-4
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
npm Ubuntu:26.04:LTS
- Версии
- 9.2.0~ds1-3
- 9.2.0~ds2-2
- 9.2.0~ds3-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/npm/cli/security/advisories/GHSA-hj9c-8jmm-8c52
- https://github.com/npm/npm-packlist
- https://github.com/npm/cli/tree/latest/workspaces/libnpmpublish
- https://github.com/npm/cli/tree/latest/workspaces/libnpmpack
- https://github.com/nodejs/node/pull/43210
- https://github.com/npm/cli/releases/tag/v8.11.0
- https://github.com/nodejs/node/releases/tag/v16.15.1
- https://github.com/nodejs/node/releases/tag/v17.9.1
- https://github.com/nodejs/node/releases/tag/v18.3.0
- https://security.netapp.com/advisory/ntap-20220722-0007/
- https://nvd.nist.gov/vuln/detail/CVE-2022-29244