CVE-2022-31015
CVE-2022-31015 · Uncaught Exception (due to a data race) leads to process termination in Waitress
CVSS 6.5 · Средний · EPSS 1,5% · Есть исправление
Затронуты ли вы?
- waitressНет опубликованного исправления
- waitress Debian 12Обновитесь до 2.1.2-1
- waitress Debian 13Обновитесь до 2.1.2-1
- waitress Debian 14Обновитесь до 2.1.2-1
- и ещё 1
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="waitress"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания waitress и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Waitress is a Web Server Gateway Interface server for Python 2 and 3. Waitress versions 2.1.0 and 2.1.1 may terminate early due to a thread closing a socket while the main thread is about to call select(). This will lead to the main thread raising an exception that is not handled and then causing the entire application to be killed. This issue has been fixed in Waitress 2.1.2 by no longer allowing the WSGI thread to close the socket. Instead, that is always delegated to the main thread. There is no work-around for this issue. However, users using waitress behind a reverse proxy server are less likely to have issues if the reverse proxy always reads the full response.
- Опубликовано
- Обновлено
Затронутые продукты и версии
waitress
- Версии
- >= 2.1.0, < 2.1.2: Затронуто
Нет опубликованного исправления
waitress Debian 12
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.2-1
Обновитесь до 2.1.2-1
waitress Debian 13
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.2-1
Обновитесь до 2.1.2-1
waitress Debian 14
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.1.2-1
Обновитесь до 2.1.2-1
waitress PyPI
- Версии
- 2.1.0
- 2.1.1
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Обновитесь до 2.1.2
waitress PyPI
- Версии
- 2.1.0
- 2.1.1
- Затронутые диапазоны версий
- GIT: < 4f6789b035610e0552738cdc4b35ca809a592d48
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Обновитесь до 2.1.2