p PatchFirst

CVE-2022-31030

CVE-2022-31030 · containerd CRI plugin: Host memory exhaustion through ExecSync

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

containerd is an open source container runtime. A bug was found in the containerd's CRI implementation where programs inside a container can cause the containerd daemon to consume memory without bound during invocation of the `ExecSync` API. This can cause containerd to consume all available memory on the computer, denying service to other legitimate workloads. Kubernetes and crictl can both be configured to use containerd's CRI implementation; `ExecSync` may be used when running probes or when executing processes via an "exec" facility. This bug has been fixed in containerd 1.6.6 and 1.5.13. Users should update to these versions to resolve the issue. Users unable to upgrade should ensure that only trusted images and commands are used.

CVSS 5.5 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: system · containers

Затронутые продукты и версии

  • containerd

    Версии
    • < 1.5.13: Затронуто
    • >= 1.6.0, < 1.6.6: Затронуто

    Нет опубликованного исправления

  • containerd Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.6~ds1-1

    Обновитесь до 1.6.6~ds1-1

  • containerd Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.6~ds1-1

    Обновитесь до 1.6.6~ds1-1

  • containerd Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.6~ds1-1

    Обновитесь до 1.6.6~ds1-1

  • containerd Ubuntu:Pro:16.04:LTS

    Версии
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm2

    Обновитесь до 1.2.6-0ubuntu1~16.04.6+esm2

  • containerd Ubuntu:18.04:LTS

    Версии
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.3
    • 1.5.5-0ubuntu3~18.04.1
    • 1.5.5-0ubuntu3~18.04.2
    • 1.5.9-0ubuntu1~18.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.5.9-0ubuntu1~18.04.2

    Обновитесь до 1.5.9-0ubuntu1~18.04.2

  • containerd Ubuntu:20.04:LTS

    Версии
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.3
    • 1.5.5-0ubuntu3~20.04.1
    • 1.5.5-0ubuntu3~20.04.2
    • 1.5.9-0ubuntu1~20.04.1
    • 1.5.9-0ubuntu1~20.04.4
    • 1.5.9-0ubuntu1~20.04.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.5.9-0ubuntu1~20.04.6

    Обновитесь до 1.5.9-0ubuntu1~20.04.6

  • containerd Ubuntu:22.04:LTS

    Версии
    • 1.5.5-0ubuntu3
    • 1.5.9-0ubuntu1
    • 1.5.9-0ubuntu2
    • 1.5.9-0ubuntu3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.5.9-0ubuntu3.1

    Обновитесь до 1.5.9-0ubuntu3.1

Первоисточники

Проверьте свой сервер →