CVE-2022-31037
CVE-2022-31037 · OroCommerce vulnerable to Cross-site Scripting via Shipping rule editing page
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
OroCommerce is an open-source Business to Business Commerce application. Versions between 4.1.0 and 4.1.17 inclusive, 4.2.0 and 4.2.11 inclusive, and between 5.0.0 and 5.0.3 inclusive, are vulnerable to Cross-site Scripting in the UPS Surcharge field of the Shipping rule edit page. The attacker needs permission to create or edit a shipping rule. This issue has been patched in version 5.0.6. There are no known workarounds.
CVSS 6.9 · Средний · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: php
Затронутые продукты и версии
orocommerce
- Версии
- >= 4.1.0, <= 4.1.17: Затронуто
- >= 4.2.0, <= 4.2.11 : Затронуто
- >= 5.0.0, <= 5.0.3: Затронуто
Нет опубликованного исправления
oro/commerce Packagist
- Версии
- 4.1.0
- 4.1.1
- 4.1.1-rc
- 4.1.1-rc2
- 4.1.10
- 4.1.11
- 4.1.12
- 4.1.13
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.1.9
- 4.2.0
- 4.2.0-alpha
- 4.2.0-alpha.1
- 4.2.0-alpha.2
- 4.2.0-alpha.3
- 4.2.0-beta
- 4.2.0-rc
- 4.2.1
- 4.2.10
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- 5.0.0
- 5.0.0-alpha.1
- 5.0.0-alpha.2
- 5.0.0-beta.1
- 5.0.0-beta.2
- 5.0.0-rc
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.0.5
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.1.0, < 5.0.6
Обновитесь до 5.0.6