p PatchFirst

CVE-2022-31170

CVE-2022-31170 · OpenZeppelin Contracts's ERC165Checker may revert instead of returning false

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

OpenZeppelin Contracts is a library for smart contract development. Versions 4.0.0 until 4.7.1 are vulnerable to ERC165Checker reverting instead of returning `false`. `ERC165Checker.supportsInterface` is designed to always successfully return a boolean, and under no circumstance revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-165 as expected, specifically if it returns a value other than 0 or 1. The contracts that may be affected are those that use `ERC165Checker` to check for support for an interface and then handle the lack of support in a way other than reverting. The issue was patched in version 4.7.1.

CVSS 7.5 · Высокий · EPSS 0,8% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • openzeppelin-contracts

    Версии
    • >= 4.0.0, < 4.7.1: Затронуто

    Нет опубликованного исправления

  • @openzeppelin/contracts npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.7.1

    Обновитесь до 4.7.1

  • @openzeppelin/contracts-upgradeable npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.7.1

    Обновитесь до 4.7.1

Первоисточники

Проверьте свой сервер →