CVE-2022-31172
CVE-2022-31172 · OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.
CVSS 7.5 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
openzeppelin-contracts
- Версии
- >= 4.1.0, < 4.7.1: Затронуто
Нет опубликованного исправления
@openzeppelin/contracts npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.1.0, < 4.7.1
Обновитесь до 4.7.1
@openzeppelin/contracts-upgradeable npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.1.0, < 4.7.1
Обновитесь до 4.7.1