p PatchFirst

CVE-2022-35650

CVE-2022-35650

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.

CVSS 7.5 · Высокий · EPSS 53,7% · Есть исправление

Опубликовано
Обновлено

Стек: system · php

Затронутые продукты и версии

  • moodle

    Версии
    • Fixed in moodle 4.0.2, moodle 3.11.8, moodle 3.9.15: Затронуто

    Нет опубликованного исправления

  • moodle/moodle Packagist

    Версии
    • v3.9.0
    • v3.9.0-beta
    • v3.9.0-rc1
    • v3.9.0-rc2
    • v3.9.0-rc3
    • v3.9.1
    • v3.9.10
    • v3.9.11
    • v3.9.12
    • v3.9.13
    • v3.9.14
    • v3.9.2
    • v3.9.3
    • v3.9.4
    • v3.9.5
    • v3.9.6
    • v3.9.7
    • v3.9.8
    • v3.9.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.9, < 3.9.15

    Обновитесь до 3.9.15

  • moodle/moodle Packagist

    Версии
    • v3.11.0
    • v3.11.0-beta
    • v3.11.0-rc1
    • v3.11.0-rc2
    • v3.11.1
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.11, < 3.11.8

    Обновитесь до 3.11.8

  • moodle/moodle Packagist

    Версии
    • v4.0.0
    • v4.0.0-beta
    • v4.0.0-rc1
    • v4.0.0-rc2
    • v4.0.0-rc3
    • v4.0.0-rc4
    • v4.0.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.0, < 4.0.2

    Обновитесь до 4.0.2

  • moodle Ubuntu:Pro:16.04:LTS

    Версии
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • moodle Ubuntu:Pro:18.04:LTS

    Версии
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →