p PatchFirst

CVE-2022-36045

CVE-2022-36045 · Account takeover via cryptographically weak PRNG in NodeBB Forum

CVSS 9.0 · Критический · EPSS 1,3% · Есть исправление

Затронуты ли вы?

  • nodebbНет опубликованного исправления
  • nodebb npmОбновитесь до 1.19.8

Как узнать установленную версию:

npm ls nodebb

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания nodebb и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

NodeBB Forum Software is powered by Node.js and supports either Redis, MongoDB, or a PostgreSQL database. It utilizes web sockets for instant interactions and real-time notifications. `utils.generateUUID`, a helper function available in essentially all versions of NodeBB (as far back as v1.0.1 and potentially earlier) used a cryptographically insecure Pseudo-random number generator (`Math.random()`), which meant that a specially crafted script combined with multiple invocations of the password reset functionality could enable an attacker to correctly calculate the reset code for an account they do not have access to. This vulnerability impacts all installations of NodeBB. The vulnerability allows for an attacker to take over any account without the involvement of the victim, and as such, the remediation should be applied immediately (either via NodeBB upgrade or cherry-pick of the specific changeset. The vulnerability has been patched in version 2.x and 1.19.x. There is no known workaround, but the patch sets listed above will fully patch the vulnerability.

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • nodebb

    Версии
    • < 1.19.8: Затронуто
    • = 2.0.0: Затронуто

    Нет опубликованного исправления

  • nodebb npm

    Затронутые диапазоны версий
    • SEMVER: < 1.19.8

    Обновитесь до 1.19.8

  • nodebb npm

    Версии
    • 2.0.0
    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.0.1

    Обновитесь до 2.0.1

Первоисточники

Проверьте свой сервер →