p PatchFirst

CVE-2022-39260

CVE-2022-39260 · Git vulnerable to Remote Code Execution via Heap overflow in `git shell`

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Git is an open source, scalable, distributed revision control system. `git shell` is a restricted login shell that can be used to implement Git's push/pull functionality via SSH. In versions prior to 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4, the function that splits the command arguments into an array improperly uses an `int` to represent the number of entries in the array, allowing a malicious actor to intentionally overflow the return value, leading to arbitrary heap writes. Because the resulting array is then passed to `execv()`, it is possible to leverage this attack to gain remote code execution on a victim machine. Note that a victim must first allow access to `git shell` as a login shell in order to be vulnerable to this attack. This problem is patched in versions 2.30.6, 2.31.5, 2.32.4, 2.33.5, 2.34.5, 2.35.5, 2.36.3, and 2.37.4 and users are advised to upgrade to the latest version. Disabling `git shell` access via remote logins is a viable short-term workaround.

CVSS 8.5 · Высокий · EPSS 4,0% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • git

    Версии
    • < 2.30.6: Затронуто
    • > 2.31.0, < 2.31.5: Затронуто
    • > 2.32.0, < 2.32.4: Затронуто
    • > 2.33.0, < 2.33.5: Затронуто
    • > 2.34.0, < 2.34.5: Затронуто
    • > 2.34.0, < 2.35.5: Затронуто
    • > 2.35.0, < 2.36.3: Затронуто
    • > 2.37.0, < 2.37.4: Затронуто

    Нет опубликованного исправления

  • git Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.38.1-1

    Обновитесь до 1:2.38.1-1

  • git Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.38.1-1

    Обновитесь до 1:2.38.1-1

  • git Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.38.1-1

    Обновитесь до 1:2.38.1-1

  • git Ubuntu:Pro:16.04:LTS

    Версии
    • 1:2.5.0-1
    • 1:2.6.2-1
    • 1:2.6.3-1
    • 1:2.6.4-1
    • 1:2.7.0~rc3-1
    • 1:2.7.0-1
    • 1:2.7.3-0ubuntu1
    • 1:2.7.4-0ubuntu1
    • 1:2.7.4-0ubuntu1.1
    • 1:2.7.4-0ubuntu1.2
    • 1:2.7.4-0ubuntu1.3
    • 1:2.7.4-0ubuntu1.4
    • 1:2.7.4-0ubuntu1.5
    • 1:2.7.4-0ubuntu1.6
    • 1:2.7.4-0ubuntu1.7
    • 1:2.7.4-0ubuntu1.8
    • 1:2.7.4-0ubuntu1.9
    • 1:2.7.4-0ubuntu1.10
    • 1:2.7.4-0ubuntu1.10+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.7.4-0ubuntu1.10+esm3

    Обновитесь до 1:2.7.4-0ubuntu1.10+esm3

  • git Ubuntu:18.04:LTS

    Версии
    • 1:2.14.1-1ubuntu4
    • 1:2.15.1-1ubuntu2
    • 1:2.17.0-1ubuntu1
    • 1:2.17.1-1ubuntu0.1
    • 1:2.17.1-1ubuntu0.3
    • 1:2.17.1-1ubuntu0.4
    • 1:2.17.1-1ubuntu0.5
    • 1:2.17.1-1ubuntu0.6
    • 1:2.17.1-1ubuntu0.7
    • 1:2.17.1-1ubuntu0.8
    • 1:2.17.1-1ubuntu0.9
    • 1:2.17.1-1ubuntu0.10
    • 1:2.17.1-1ubuntu0.11
    • 1:2.17.1-1ubuntu0.12
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.17.1-1ubuntu0.13

    Обновитесь до 1:2.17.1-1ubuntu0.13

  • git Ubuntu:20.04:LTS

    Версии
    • 1:2.20.1-2ubuntu1
    • 1:2.24.0-1ubuntu1
    • 1:2.24.0-1ubuntu2
    • 1:2.25.0-1ubuntu1
    • 1:2.25.1-1ubuntu1
    • 1:2.25.1-1ubuntu2
    • 1:2.25.1-1ubuntu3
    • 1:2.25.1-1ubuntu3.1
    • 1:2.25.1-1ubuntu3.2
    • 1:2.25.1-1ubuntu3.3
    • 1:2.25.1-1ubuntu3.4
    • 1:2.25.1-1ubuntu3.5
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.25.1-1ubuntu3.6

    Обновитесь до 1:2.25.1-1ubuntu3.6

  • git Ubuntu:22.04:LTS

    Версии
    • 1:2.32.0-1ubuntu1
    • 1:2.33.1-1ubuntu1
    • 1:2.34.1-1ubuntu1
    • 1:2.34.1-1ubuntu1.1
    • 1:2.34.1-1ubuntu1.2
    • 1:2.34.1-1ubuntu1.4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:2.34.1-1ubuntu1.5

    Обновитесь до 1:2.34.1-1ubuntu1.5

Первоисточники

Проверьте свой сервер →