p PatchFirst

CVE-2022-3978

CVE-2022-3978 · NodeBB abort cross-site request forgery

CVSS 4.3 · Средний · EPSS 0,4% · Есть исправление

Затронуты ли вы?

  • nodebbНет опубликованного исправления
  • nodebb npmОбновитесь до 2.5.8

Как узнать установленную версию:

npm ls nodebb

Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания nodebb и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.

curl -fsSL https://ru.patchfirst.dev/check.sh | sh
Проверить сервер бесплатно →

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • nodebb

    Версии
    • 2.5.0: Затронуто
    • 2.5.1: Затронуто
    • 2.5.2: Затронуто
    • 2.5.3: Затронуто
    • 2.5.4: Затронуто
    • 2.5.5: Затронуто
    Все версии (8)
    • 2.5.6: Затронуто
    • 2.5.7: Затронуто

    Нет опубликованного исправления

  • nodebb npm

    Затронутые диапазоны версий
    • SEMVER: < 2.5.8

    Обновитесь до 2.5.8

Первоисточники

Проверьте свой сервер →