p PatchFirst

CVE-2022-40735

CVE-2022-40735

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The Diffie-Hellman Key Agreement Protocol allows use of long exponents that arguably make certain calculations unnecessarily expensive, because the 1996 van Oorschot and Wiener paper found that "(appropriately) short exponents" can be used when there are adequate subgroup constraints, and these short exponents can lead to less expensive calculations than for long exponents. This issue is different from CVE-2002-20001 because it is based on an observation about exponent size, rather than an observation about numbers that are not public keys. The specific situations in which calculation expense would constitute a server-side vulnerability depend on the protocol (e.g., TLS, SSH, or IKE) and the DHE implementation details. In general, there might be an availability concern because of server-side resource consumption from DHE modular-exponentiation calculations. Finally, it is possible for an attacker to exploit this vulnerability and CVE-2002-20001 together.

CVSS 7.5 · Высокий · EPSS 2,6% · Есть исправление

Опубликовано
Обновлено

Стек: system · network

Затронутые продукты и версии

  • n/a

    Версии
    • n/a: Затронуто

    Нет опубликованного исправления

  • openssl Ubuntu:22.04:LTS

    Версии
    • 1.1.1l-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-0ubuntu1
    • 3.0.2-0ubuntu1
    • 3.0.2-0ubuntu1.1
    • 3.0.2-0ubuntu1.2
    • 3.0.2-0ubuntu1.4
    • 3.0.2-0ubuntu1.5
    • 3.0.2-0ubuntu1.6
    • 3.0.2-0ubuntu1.7
    • 3.0.2-0ubuntu1.8
    • 3.0.2-0ubuntu1.9
    • 3.0.2-0ubuntu1.10
    • 3.0.2-0ubuntu1.12
    • 3.0.2-0ubuntu1.13
    • 3.0.2-0ubuntu1.14
    • 3.0.2-0ubuntu1.15
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.0.2-0ubuntu1.16

    Обновитесь до 3.0.2-0ubuntu1.16

  • nodejs Ubuntu:Pro:22.04:LTS

    Версии
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • openssl Ubuntu:Pro:FIPS-preview:22.04:LTS

    Версии
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • openssl Ubuntu:Pro:FIPS-updates:22.04:LTS

    Версии
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    • 3.0.2-0ubuntu1.14+Fips1
    • 3.0.2-0ubuntu1.15+Fips1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.0.2-0ubuntu1.16+Fips1

    Обновитесь до 3.0.2-0ubuntu1.16+Fips1

Первоисточники

Проверьте свой сервер →