p PatchFirst

CVE-2022-41881

CVE-2022-41881

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.

CVSS 5.3 · Средний · EPSS 1,6% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • netty

    Версии
    • < 4.1.86.Final: Затронуто

    Нет опубликованного исправления

  • netty Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-6

    Обновитесь до 1:4.1.48-6

  • netty Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-6

    Обновитесь до 1:4.1.48-6

  • netty Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-6

    Обновитесь до 1:4.1.48-6

  • netty Ubuntu:Pro:14.04:LTS

    Версии
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • netty Ubuntu:Pro:16.04:LTS

    Версии
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1

    Обновитесь до 1:4.0.34-1ubuntu0.1~esm1

  • netty-3.9 Ubuntu:16.04:LTS

    Версии
    • 3.9.0.Final-1
    • 3.9.0.Final-1ubuntu0.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • netty Ubuntu:Pro:18.04:LTS

    Версии
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2

    Обновитесь до 1:4.1.7-4ubuntu0.1+esm2

  • netty-3.9 Ubuntu:18.04:LTS

    Версии
    • 3.9.9.Final-1
    • 3.9.9.Final-1+deb9u1build0.18.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • netty Ubuntu:Pro:20.04:LTS

    Версии
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1

    Обновитесь до 1:4.1.45-1ubuntu0.1~esm1

  • netty Ubuntu:22.04:LTS

    Версии
    • 1:4.1.48-4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1

    Обновитесь до 1:4.1.48-4+deb11u1build0.22.04.1

Первоисточники

Проверьте свой сервер →