p PatchFirst

CVE-2022-41905

CVE-2022-41905 · wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.

CVSS 8.2 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • wsgidav

    Версии
    • >= 3.0.0a1, < 4.1.0: Затронуто

    Нет опубликованного исправления

  • wsgidav PyPI

    Версии
    • 3.0.0
    • 3.0.0a1
    • 3.0.0a2
    • 3.0.0a3
    • 3.0.0a4
    • 3.0.0a5
    • 3.0.0a6
    • 3.0.0a7
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.5a2
    • 3.0.5a3
    • 3.1.0
    • 3.1.1
    • 4.0.0
    • 4.0.0a2
    • 4.0.1
    • 4.0.2
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.0.0a1, < 4.1.0

    Обновитесь до 4.1.0

  • wsgidav PyPI

    Версии
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.5a2
    • 3.0.5a3
    • 3.1.0
    • 3.1.1
    • 4.0.0
    • 4.0.0a2
    • 4.0.1
    • 4.0.2
    Затронутые диапазоны версий
    • GIT: < e9606ab0f42f4c1a6611bc3c52de299b0aba7726
    • ECOSYSTEM: ≥ 3.0.0, < 4.1.0

    Обновитесь до 4.1.0

Первоисточники

Проверьте свой сервер →