p PatchFirst

CVE-2022-42920

CVE-2022-42920 · Apache Commons BCEL prior to 6.6.0 allows producing arbitrary bytecode via out-of-bounds writing

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Apache Commons BCEL has a number of APIs that would normally only allow changing specific class characteristics. However, due to an out-of-bounds writing issue, these APIs can be used to produce arbitrary bytecode. This could be abused in applications that pass attacker-controllable data to those APIs, giving the attacker more control over the resulting bytecode than otherwise expected. Update to Apache Commons BCEL 6.6.0.

CVSS 9.8 · Критический · EPSS 2,8% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache commons bcel

    Версии
    • ≥ Apache Commons BCEL, < 6.6.0: Затронуто (custom)

    Обновитесь до 6.6.0

  • bcel Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.5.0-2

    Обновитесь до 6.5.0-2

  • bcel Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.5.0-2

    Обновитесь до 6.5.0-2

  • bcel Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.5.0-2

    Обновитесь до 6.5.0-2

  • bcel Ubuntu:Pro:16.04:LTS

    Версии
    • 6.0~rc3-1ubuntu1
    • 6.0~rc3-2ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.0~rc3-2ubuntu1+esm1

    Обновитесь до 6.0~rc3-2ubuntu1+esm1

  • bcel Ubuntu:Pro:18.04:LTS

    Версии
    • 6.0-1
    • 6.1-1
    • 6.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.2-1ubuntu0.1~esm1

    Обновитесь до 6.2-1ubuntu0.1~esm1

  • bcel Ubuntu:Pro:20.04:LTS

    Версии
    • 6.3-1
    • 6.4.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.4.1-1ubuntu0.1~esm1

    Обновитесь до 6.4.1-1ubuntu0.1~esm1

  • bcel Ubuntu:22.04:LTS

    Версии
    • 6.5.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.5.0-1ubuntu0.1

    Обновитесь до 6.5.0-1ubuntu0.1

Первоисточники

Проверьте свой сервер →