p PatchFirst

CVE-2022-45149

CVE-2022-45149

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was found in Moodle which exists due to insufficient validation of the HTTP request origin in course redirect URL. A user's CSRF token was unnecessarily included in the URL when being redirected to a course they have just restored. A remote attacker can trick the victim to visit a specially crafted web page and perform arbitrary actions on behalf of the victim on the vulnerable website. This flaw allows an attacker to perform cross-site request forgery attacks.

CVSS 5.4 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: system · php

Затронутые продукты и версии

  • moodle

    Версии
    • Fixed in moodle 4.0.5, moodle 3.11.11, moodle 3.9.18: Затронуто

    Нет опубликованного исправления

  • moodle/moodle Packagist

    Версии
    • v3.9.0
    • v3.9.1
    • v3.9.10
    • v3.9.11
    • v3.9.12
    • v3.9.13
    • v3.9.14
    • v3.9.15
    • v3.9.16
    • v3.9.17
    • v3.9.2
    • v3.9.3
    • v3.9.4
    • v3.9.5
    • v3.9.6
    • v3.9.7
    • v3.9.8
    • v3.9.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.9.0, < 3.9.18

    Обновитесь до 3.9.18

  • moodle/moodle Packagist

    Версии
    • v3.11.0
    • v3.11.1
    • v3.11.10
    • v3.11.2
    • v3.11.3
    • v3.11.4
    • v3.11.5
    • v3.11.6
    • v3.11.7
    • v3.11.8
    • v3.11.9
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.11.0, < 3.11.11

    Обновитесь до 3.11.11

  • moodle/moodle Packagist

    Версии
    • v4.0.0
    • v4.0.1
    • v4.0.2
    • v4.0.3
    • v4.0.4
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.0.0, < 4.0.5

    Обновитесь до 4.0.5

  • moodle Ubuntu:Pro:16.04:LTS

    Версии
    • 2.7.9+dfsg-1
    • 2.7.10+dfsg-1
    • 2.7.11+dfsg-1
    • 2.7.11+dfsg-2
    • 2.7.12+dfsg-1
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • moodle Ubuntu:Pro:18.04:LTS

    Версии
    • 3.0.3+dfsg-0ubuntu1
    • 3.0.3+dfsg-0ubuntu1+esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →