CVE-2022-48503
CVE-2022-48503
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.
The issue was addressed with improved bounds checks. This issue is fixed in tvOS 15.6, watchOS 8.7, iOS 15.6 and iPadOS 15.6, macOS Monterey 12.5, Safari 15.6. Processing web content may lead to arbitrary code execution.
CVSS 8.8 · Высокий · EPSS 3,2% · В каталоге KEV · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
macos
- Версии
- ≥ unspecified, < 12.5: Затронуто (custom)
Обновитесь до 12.5
tvos
- Версии
- ≥ unspecified, < 15.6: Затронуто (custom)
Обновитесь до 15.6
safari
- Версии
- ≥ unspecified, < 15.6: Затронуто (custom)
Обновитесь до 15.6
watchos
- Версии
- ≥ unspecified, < 8.7: Затронуто (custom)
Обновитесь до 8.7
ios and ipados
- Версии
- ≥ unspecified, < 15.6: Затронуто (custom)
Обновитесь до 15.6
webkit2gtk Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.0-1
Обновитесь до 2.38.0-1
webkit2gtk Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.0-1
Обновитесь до 2.38.0-1
webkit2gtk Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.0-1
Обновитесь до 2.38.0-1
wpewebkit Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.0-1
Обновитесь до 2.38.0-1
wpewebkit Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.0-1
Обновитесь до 2.38.0-1
wpewebkit Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.0-1
Обновитесь до 2.38.0-1
qtwebkit-opensource-src Ubuntu:16.04:LTS
- Версии
- 5.4.2+dfsg-1ubuntu2.1
- 5.5.1+dfsg-2ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
webkit2gtk Ubuntu:16.04:LTS
- Версии
- 2.8.5+dfsg1-3
- 2.10.3+dfsg1-1
- 2.10.4+dfsg1-1
- 2.10.5-1
- 2.10.6-1
- 2.10.6-1ubuntu1
- 2.10.8-1ubuntu1
- 2.10.9-1ubuntu1
- 2.12.5-0ubuntu0.16.04.1
- 2.14.2-0ubuntu0.16.04.1
- 2.14.3-0ubuntu0.16.04.1
- 2.14.5-0ubuntu0.16.04.1
- 2.16.1-0ubuntu0.16.04.1
- 2.16.1-0ubuntu0.16.04.2
- 2.16.2-0ubuntu0.16.04.1
- 2.16.3-0ubuntu0.16.04.1
- 2.16.6-0ubuntu0.16.04.1
- 2.18.0-0ubuntu0.16.04.2
- 2.18.3-0ubuntu0.16.04.1
- 2.18.4-0ubuntu0.16.04.1
- 2.18.5-0ubuntu0.16.04.1
- 2.18.6-0ubuntu0.16.04.1
- 2.20.1-0ubuntu0.16.04.1
- 2.20.2-0ubuntu0.16.04.1
- 2.20.3-0ubuntu0.16.04.1
- 2.20.5-0ubuntu0.16.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qtwebkit-source Ubuntu:16.04:LTS
- Версии
- 2.3.2-0ubuntu10
- 2.3.2-0ubuntu11
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
webkitgtk Ubuntu:16.04:LTS
- Версии
- 2.4.9-2ubuntu2
- 2.4.10-0ubuntu1
- 2.4.11-0ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
webkit2gtk Ubuntu:18.04:LTS
- Версии
- 2.18.0-2
- 2.18.0-2build1
- 2.18.2-1
- 2.18.3-1
- 2.18.4-1
- 2.18.6-1
- 2.19.91-1ubuntu1
- 2.19.92-1
- 2.20.0-1
- 2.20.0-2
- 2.20.0-2ubuntu1
- 2.20.1-1
- 2.20.2-0ubuntu0.18.04.1
- 2.20.3-0ubuntu0.18.04.1
- 2.20.5-0ubuntu0.18.04.1
- 2.22.2-0ubuntu0.18.04.1
- 2.22.2-0ubuntu0.18.04.2
- 2.22.4-0ubuntu0.18.04.1
- 2.22.5-0ubuntu0.18.04.1
- 2.22.6-0ubuntu0.18.04.1
- 2.24.1-0ubuntu0.18.04.1
- 2.24.2-0ubuntu0.18.04.1
- 2.24.4-0ubuntu0.18.04.1
- 2.26.1-0ubuntu0.18.04.1
- 2.26.2-0ubuntu0.18.04.1
- 2.26.3-0ubuntu0.18.04.1
- 2.26.4-0ubuntu0.18.04.1
- 2.28.0-0ubuntu0.18.04.3
- 2.28.1-0ubuntu0.18.04.1
- 2.28.2-0ubuntu0.18.04.1
- 2.28.3-0ubuntu0.18.04.1
- 2.28.4-0ubuntu0.18.04.1
- 2.30.3-0ubuntu0.18.04.1
- 2.30.5-0ubuntu0.18.04.1
- 2.30.6-0ubuntu0.18.04.1
- 2.32.0-0ubuntu0.18.04.1
- 2.32.3-0ubuntu0.18.04.1
- 2.32.4-0ubuntu0.18.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qtwebkit-opensource-src Ubuntu:18.04:LTS
- Версии
- 5.9.1+dfsg-5ubuntu1
- 5.9.1+dfsg-5ubuntu3
- 5.212.0~alpha2-5build2
- 5.212.0~alpha2-5build4
- 5.212.0~alpha2-7
- 5.212.0~alpha2-7build2
- 5.212.0~alpha2-7ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qtwebkit-source Ubuntu:18.04:LTS
- Версии
- 2.3.2-0ubuntu13
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
webkitgtk Ubuntu:18.04:LTS
- Версии
- 2.4.11-3
- 2.4.11-3ubuntu2
- 2.4.11-3ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
webkit2gtk Ubuntu:20.04:LTS
- Версии
- 2.26.1-3
- 2.26.2-1
- 2.26.3-1ubuntu2
- 2.26.4-1ubuntu1
- 2.28.0-1ubuntu2
- 2.28.1-1
- 2.28.2-0ubuntu0.20.04.1
- 2.28.3-0ubuntu0.20.04.1
- 2.28.4-0ubuntu0.20.04.1
- 2.30.3-0ubuntu0.20.04.1
- 2.30.5-0ubuntu0.20.04.1
- 2.30.6-0ubuntu0.20.04.1
- 2.32.0-0ubuntu0.20.04.1
- 2.32.3-0ubuntu0.20.04.1
- 2.32.4-0ubuntu0.20.04.1
- 2.34.1-0ubuntu0.20.04.1
- 2.34.3-0ubuntu0.20.04.1
- 2.34.4-0ubuntu0.20.04.1
- 2.34.6-0ubuntu0.20.04.1
- 2.36.0-0ubuntu0.20.04.3
- 2.36.2-0ubuntu0.20.04.1
- 2.36.3-0ubuntu0.20.04.1
- 2.36.4-0ubuntu0.20.04.1
- 2.36.6-0ubuntu0.20.04.1
- 2.36.7-0ubuntu0.20.04.1
- 2.36.8-0ubuntu0.20.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.2-0ubuntu0.20.04.1
Обновитесь до 2.38.2-0ubuntu0.20.04.1
qtwebkit-opensource-src Ubuntu:20.04:LTS
- Версии
- 5.212.0~alpha3-3
- 5.212.0~alpha3-5
- 5.212.0~alpha3-6
- 5.212.0~alpha3-7
- 5.212.0~alpha4-1
- 5.212.0~alpha4-1ubuntu1
- 5.212.0~alpha4-1ubuntu2
- 5.212.0~alpha4-1ubuntu2.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
wpewebkit Ubuntu:20.04:LTS
- Версии
- 2.26.3-1
- 2.26.4-1
- 2.26.4-1build1
- 2.28.0-1
- 2.28.1-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
qtwebkit-opensource-src Ubuntu:22.04:LTS
- Версии
- 5.212.0~alpha4-12
- 5.212.0~alpha4-13
- 5.212.0~alpha4-14
- 5.212.0~alpha4-14build1
- 5.212.0~alpha4-14ubuntu2
- 5.212.0~alpha4-15ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
webkit2gtk Ubuntu:22.04:LTS
- Версии
- 2.34.0-1ubuntu1
- 2.34.1-1ubuntu1
- 2.34.2-1ubuntu1
- 2.34.3-1
- 2.35.3-1ubuntu1
- 2.35.90-1ubuntu1
- 2.36.0-2ubuntu1
- 2.36.2-0ubuntu0.22.04.1
- 2.36.3-0ubuntu0.22.04.1
- 2.36.4-0ubuntu0.22.04.1
- 2.36.6-0ubuntu0.22.04.1
- 2.36.7-0ubuntu0.22.04.1
- 2.36.8-0ubuntu0.22.04.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.38.2-0ubuntu0.22.04.2
Обновитесь до 2.38.2-0ubuntu0.22.04.2
Первоисточники
- https://support.apple.com/en-us/HT213345
- https://support.apple.com/en-us/HT213342
- https://support.apple.com/en-us/HT213341
- https://support.apple.com/en-us/HT213340
- https://support.apple.com/en-us/HT213346
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2022-48503
- https://nvd.nist.gov/vuln/detail/CVE-2022-48503