CVE-2023-22727
CVE-2023-22727 · Database Query::offset() and limit() vulnerable to SQL injection in cakephp
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
CakePHP is a development framework for PHP web apps. In affected versions the `Cake\Database\Query::limit()` and `Cake\Database\Query::offset()` methods are vulnerable to SQL injection if passed un-sanitized user request data. This issue has been fixed in 4.2.12, 4.3.11, 4.4.10. Users are advised to upgrade. Users unable to upgrade may mitigate this issue by using CakePHP's Pagination library. Manually validating or casting parameters to these methods will also mitigate the issue.
CVSS 9.8 · Критический · EPSS 0,9% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
cakephp
- Версии
- >= 4.2.0, < 4.2.12: Затронуто
- >= 4.3.0, < 4.3.11: Затронуто
- >= 4.4.0, < 4.4.10: Затронуто
Нет опубликованного исправления
cakephp/cakephp Packagist
- Версии
- 4.2.0
- 4.2.1
- 4.2.10
- 4.2.11
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.2.0, < 4.2.12
Обновитесь до 4.2.12
cakephp/cakephp Packagist
- Версии
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.3.0, < 4.3.11
Обновитесь до 4.3.11
cakephp/cakephp Packagist
- Версии
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.4.0, < 4.4.10
Обновитесь до 4.4.10
cakephp/database Packagist
- Версии
- 4.2.0
- 4.2.1
- 4.2.10
- 4.2.11
- 4.2.2
- 4.2.3
- 4.2.4
- 4.2.5
- 4.2.6
- 4.2.7
- 4.2.8
- 4.2.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.2.0, < 4.2.12
Обновитесь до 4.2.12
cakephp/database Packagist
- Версии
- 4.3.0
- 4.3.1
- 4.3.10
- 4.3.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.3.6
- 4.3.7
- 4.3.8
- 4.3.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.3.0, < 4.3.11
Обновитесь до 4.3.11
cakephp/database Packagist
- Версии
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.4.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 4.4.0, < 4.4.10
Обновитесь до 4.4.10
cakephp Ubuntu:16.04:LTS
- Версии
- 2.7.2-1
- 2.8.0-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
cakephp Ubuntu:20.04:LTS
- Версии
- 2.10.11-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
cakephp Ubuntu:22.04:LTS
- Версии
- 2.10.11-2.1
- 2.10.24-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления