p PatchFirst

CVE-2023-22946

CVE-2023-22946 · Apache Spark proxy-user privilege escalation from malicious configuration class

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications. Update to Apache Spark 3.4.0 or later, and ensure that spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its default of "false", and is not overridden by submitted applications.

CVSS 6.4 · Средний · EPSS 1,1% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • apache spark

    Версии
    • ≥ 0, < 3.4.0: Затронуто (semver)

    Обновитесь до 3.4.0

  • org.apache.spark:spark-core_2.12 Maven

    Версии
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.4.6
    • 2.4.7
    • 2.4.8
    • 3.0.0
    • 3.0.0-preview
    • 3.0.0-preview2
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.3.0
    • 3.3.1
    • 3.3.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.3

    Обновитесь до 3.3.3

  • org.apache.spark:spark-core_2.13 Maven

    Версии
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.3.0
    • 3.3.1
    • 3.3.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.3

    Обновитесь до 3.3.3

  • pyspark PyPI

    Версии
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.4.6
    • 2.4.7
    • 2.4.8
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.3.0
    • 3.3.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.3.2

    Обновитесь до 3.3.2

  • pyspark PyPI

    Версии
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.4.0
    • 2.4.1
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.4.6
    • 2.4.7
    • 2.4.8
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.2.0
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.3.4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 3.4.0

    Обновитесь до 3.4.0

Первоисточники

Проверьте свой сервер →