CVE-2023-23914
CVE-2023-23914
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A cleartext transmission of sensitive information vulnerability exists in curl <v7.88.0 that could cause HSTS functionality fail when multiple URLs are requested serially. Using its HSTS support, curl can be instructed to use HTTPS instead of usingan insecure clear-text HTTP step even when HTTP is provided in the URL. ThisHSTS mechanism would however surprisingly be ignored by subsequent transferswhen done on the same command line because the state would not be properlycarried on.
CVSS 9.1 · Критический · EPSS 0,9% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
https://github.com/curl/curl
- Версии
- Fixed in 7.88.0: Затронуто
Нет опубликованного исправления
curl Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.88.1-1
Обновитесь до 7.88.1-1
curl Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.88.1-1
Обновитесь до 7.88.1-1
curl Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.88.1-1
Обновитесь до 7.88.1-1
curl Ubuntu:22.04:LTS
- Версии
- 7.74.0-1.3ubuntu2
- 7.74.0-1.3ubuntu3
- 7.80.0-3
- 7.81.0-1
- 7.81.0-1ubuntu1.1
- 7.81.0-1ubuntu1.2
- 7.81.0-1ubuntu1.3
- 7.81.0-1ubuntu1.4
- 7.81.0-1ubuntu1.6
- 7.81.0-1ubuntu1.7
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.81.0-1ubuntu1.8
Обновитесь до 7.81.0-1ubuntu1.8