p PatchFirst

CVE-2023-25690

CVE-2023-25690 · Apache HTTP Server: HTTP request splitting with mod_rewrite and mod_proxy

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Some mod_proxy configurations on Apache HTTP Server versions 2.4.0 through 2.4.55 allow a HTTP Request Smuggling attack. Configurations are affected when mod_proxy is enabled along with some form of RewriteRule or ProxyPassMatch in which a non-specific pattern matches some portion of the user-supplied request-target (URL) data and is then re-inserted into the proxied request-target using variable substitution. For example, something like: RewriteEngine on RewriteRule "^/here/(.*)" "http://example.com:8080/elsewhere?$1"; [P] ProxyPassReverse /here/ http://example.com:8080/ Request splitting/smuggling could result in bypass of access controls in the proxy server, proxying unintended URLs to existing origin servers, and cache poisoning. Users are recommended to update to at least version 2.4.56 of Apache HTTP Server.

CVSS 9.8 · Критический · EPSS 84,5% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: system · web

Затронутые продукты и версии

  • apache httpd

    Версии
    • ≥ 2.4.0, ≤ 2.4.55: Затронуто (semver)

    Нет опубликованного исправления

  • apache2 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.56-1

    Обновитесь до 2.4.56-1

  • apache2 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.56-1

    Обновитесь до 2.4.56-1

  • apache2 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.56-1

    Обновитесь до 2.4.56-1

  • apache2 Ubuntu:Pro:14.04:LTS

    Версии
    • 2.4.6-2ubuntu2
    • 2.4.6-2ubuntu3
    • 2.4.6-2ubuntu4
    • 2.4.7-1ubuntu1
    • 2.4.7-1ubuntu2
    • 2.4.7-1ubuntu3
    • 2.4.7-1ubuntu4
    • 2.4.7-1ubuntu4.1
    • 2.4.7-1ubuntu4.4
    • 2.4.7-1ubuntu4.5
    • 2.4.7-1ubuntu4.6
    • 2.4.7-1ubuntu4.7
    • 2.4.7-1ubuntu4.8
    • 2.4.7-1ubuntu4.9
    • 2.4.7-1ubuntu4.10
    • 2.4.7-1ubuntu4.11
    • 2.4.7-1ubuntu4.13
    • 2.4.7-1ubuntu4.15
    • 2.4.7-1ubuntu4.16
    • 2.4.7-1ubuntu4.17
    • 2.4.7-1ubuntu4.18
    • 2.4.7-1ubuntu4.19
    • 2.4.7-1ubuntu4.20
    • 2.4.7-1ubuntu4.21
    • 2.4.7-1ubuntu4.22
    • 2.4.7-1ubuntu4.22+esm1
    • 2.4.7-1ubuntu4.22+esm2
    • 2.4.7-1ubuntu4.22+esm3
    • 2.4.7-1ubuntu4.22+esm4
    • 2.4.7-1ubuntu4.22+esm5
    • 2.4.7-1ubuntu4.22+esm6
    • 2.4.7-1ubuntu4.22+esm8
    • 2.4.7-1ubuntu4.22+esm9
    • 2.4.7-1ubuntu4.22+esm10
    • 2.4.7-1ubuntu4.22+esm12
    • 2.4.7-1ubuntu4.22+esm13
    • 2.4.7-1ubuntu4.22+esm14
    • 2.4.7-1ubuntu4.22+esm15
    • 2.4.7-1ubuntu4.22+esm16
    • 2.4.7-1ubuntu4.22+esm17
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • apache2 Ubuntu:Pro:16.04:LTS

    Версии
    • 2.4.12-2ubuntu2
    • 2.4.17-1ubuntu1
    • 2.4.17-2ubuntu1
    • 2.4.17-3ubuntu1
    • 2.4.18-1ubuntu1
    • 2.4.18-2ubuntu1
    • 2.4.18-2ubuntu2
    • 2.4.18-2ubuntu3
    • 2.4.18-2ubuntu3.1
    • 2.4.18-2ubuntu3.2
    • 2.4.18-2ubuntu3.3
    • 2.4.18-2ubuntu3.4
    • 2.4.18-2ubuntu3.5
    • 2.4.18-2ubuntu3.7
    • 2.4.18-2ubuntu3.8
    • 2.4.18-2ubuntu3.9
    • 2.4.18-2ubuntu3.10
    • 2.4.18-2ubuntu3.12
    • 2.4.18-2ubuntu3.13
    • 2.4.18-2ubuntu3.14
    • 2.4.18-2ubuntu3.15
    • 2.4.18-2ubuntu3.17
    • 2.4.18-2ubuntu3.17+esm1
    • 2.4.18-2ubuntu3.17+esm2
    • 2.4.18-2ubuntu3.17+esm3
    • 2.4.18-2ubuntu3.17+esm4
    • 2.4.18-2ubuntu3.17+esm5
    • 2.4.18-2ubuntu3.17+esm6
    • 2.4.18-2ubuntu3.17+esm7
    • 2.4.18-2ubuntu3.17+esm8
    • 2.4.18-2ubuntu3.17+esm9
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.18-2ubuntu3.17+esm10

    Обновитесь до 2.4.18-2ubuntu3.17+esm10

  • apache2 Ubuntu:18.04:LTS

    Версии
    • 2.4.27-2ubuntu3
    • 2.4.29-1ubuntu1
    • 2.4.29-1ubuntu2
    • 2.4.29-1ubuntu3
    • 2.4.29-1ubuntu4
    • 2.4.29-1ubuntu4.1
    • 2.4.29-1ubuntu4.2
    • 2.4.29-1ubuntu4.3
    • 2.4.29-1ubuntu4.4
    • 2.4.29-1ubuntu4.5
    • 2.4.29-1ubuntu4.6
    • 2.4.29-1ubuntu4.7
    • 2.4.29-1ubuntu4.8
    • 2.4.29-1ubuntu4.10
    • 2.4.29-1ubuntu4.11
    • 2.4.29-1ubuntu4.12
    • 2.4.29-1ubuntu4.13
    • 2.4.29-1ubuntu4.14
    • 2.4.29-1ubuntu4.16
    • 2.4.29-1ubuntu4.17
    • 2.4.29-1ubuntu4.18
    • 2.4.29-1ubuntu4.19
    • 2.4.29-1ubuntu4.20
    • 2.4.29-1ubuntu4.21
    • 2.4.29-1ubuntu4.22
    • 2.4.29-1ubuntu4.23
    • 2.4.29-1ubuntu4.24
    • 2.4.29-1ubuntu4.25
    • 2.4.29-1ubuntu4.26
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.29-1ubuntu4.27

    Обновитесь до 2.4.29-1ubuntu4.27

  • apache2 Ubuntu:20.04:LTS

    Версии
    • 2.4.41-1ubuntu1
    • 2.4.41-4ubuntu1
    • 2.4.41-4ubuntu2
    • 2.4.41-4ubuntu3
    • 2.4.41-4ubuntu3.1
    • 2.4.41-4ubuntu3.3
    • 2.4.41-4ubuntu3.4
    • 2.4.41-4ubuntu3.5
    • 2.4.41-4ubuntu3.6
    • 2.4.41-4ubuntu3.7
    • 2.4.41-4ubuntu3.8
    • 2.4.41-4ubuntu3.9
    • 2.4.41-4ubuntu3.10
    • 2.4.41-4ubuntu3.11
    • 2.4.41-4ubuntu3.12
    • 2.4.41-4ubuntu3.13
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.41-4ubuntu3.14

    Обновитесь до 2.4.41-4ubuntu3.14

  • apache2 Ubuntu:22.04:LTS

    Версии
    • 2.4.48-3.1ubuntu3
    • 2.4.48-3.1ubuntu4
    • 2.4.51-2ubuntu1
    • 2.4.52-1ubuntu1
    • 2.4.52-1ubuntu2
    • 2.4.52-1ubuntu4
    • 2.4.52-1ubuntu4.1
    • 2.4.52-1ubuntu4.2
    • 2.4.52-1ubuntu4.3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.52-1ubuntu4.4

    Обновитесь до 2.4.52-1ubuntu4.4

Первоисточники

Проверьте свой сервер →