CVE-2023-27533
CVE-2023-27533
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
A vulnerability in input validation exists in curl <8.0 during communication using the TELNET protocol may allow an attacker to pass on maliciously crafted user name and "telnet options" during server negotiation. The lack of proper input scrubbing allows an attacker to send content or perform option negotiation without the application's intent. This vulnerability could be exploited if an application allows user input, thereby enabling attackers to execute arbitrary code on the system.
CVSS 9.8 · Критический · EPSS 2,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
https://github.com/curl/curl
- Версии
- Fixed in 8.0.0: Затронуто
Нет опубликованного исправления
curl Debian:12
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.88.1-7
Обновитесь до 7.88.1-7
curl Debian:13
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.88.1-7
Обновитесь до 7.88.1-7
curl Debian:14
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.88.1-7
Обновитесь до 7.88.1-7
curl Ubuntu:Pro:14.04:LTS
- Версии
- 7.32.0-1ubuntu1
- 7.33.0-1ubuntu1
- 7.34.0-1ubuntu1
- 7.35.0-1ubuntu1
- 7.35.0-1ubuntu2
- 7.35.0-1ubuntu2.1
- 7.35.0-1ubuntu2.2
- 7.35.0-1ubuntu2.3
- 7.35.0-1ubuntu2.5
- 7.35.0-1ubuntu2.6
- 7.35.0-1ubuntu2.7
- 7.35.0-1ubuntu2.8
- 7.35.0-1ubuntu2.9
- 7.35.0-1ubuntu2.10
- 7.35.0-1ubuntu2.11
- 7.35.0-1ubuntu2.12
- 7.35.0-1ubuntu2.13
- 7.35.0-1ubuntu2.14
- 7.35.0-1ubuntu2.15
- 7.35.0-1ubuntu2.16
- 7.35.0-1ubuntu2.17
- 7.35.0-1ubuntu2.19
- 7.35.0-1ubuntu2.20
- 7.35.0-1ubuntu2.20+esm2
- 7.35.0-1ubuntu2.20+esm3
- 7.35.0-1ubuntu2.20+esm4
- 7.35.0-1ubuntu2.20+esm5
- 7.35.0-1ubuntu2.20+esm6
- 7.35.0-1ubuntu2.20+esm7
- 7.35.0-1ubuntu2.20+esm8
- 7.35.0-1ubuntu2.20+esm9
- 7.35.0-1ubuntu2.20+esm10
- 7.35.0-1ubuntu2.20+esm11
- 7.35.0-1ubuntu2.20+esm12
- 7.35.0-1ubuntu2.20+esm13
- 7.35.0-1ubuntu2.20+esm14
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.35.0-1ubuntu2.20+esm15
Обновитесь до 7.35.0-1ubuntu2.20+esm15
curl Ubuntu:Pro:16.04:LTS
- Версии
- 7.43.0-1ubuntu2
- 7.45.0-1ubuntu1
- 7.46.0-1ubuntu1
- 7.47.0-1ubuntu1
- 7.47.0-1ubuntu2
- 7.47.0-1ubuntu2.1
- 7.47.0-1ubuntu2.2
- 7.47.0-1ubuntu2.3
- 7.47.0-1ubuntu2.4
- 7.47.0-1ubuntu2.5
- 7.47.0-1ubuntu2.6
- 7.47.0-1ubuntu2.7
- 7.47.0-1ubuntu2.8
- 7.47.0-1ubuntu2.9
- 7.47.0-1ubuntu2.11
- 7.47.0-1ubuntu2.12
- 7.47.0-1ubuntu2.13
- 7.47.0-1ubuntu2.14
- 7.47.0-1ubuntu2.15
- 7.47.0-1ubuntu2.16
- 7.47.0-1ubuntu2.18
- 7.47.0-1ubuntu2.19
- 7.47.0-1ubuntu2.19+esm1
- 7.47.0-1ubuntu2.19+esm2
- 7.47.0-1ubuntu2.19+esm3
- 7.47.0-1ubuntu2.19+esm4
- 7.47.0-1ubuntu2.19+esm5
- 7.47.0-1ubuntu2.19+esm6
- 7.47.0-1ubuntu2.19+esm7
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.47.0-1ubuntu2.19+esm8
Обновитесь до 7.47.0-1ubuntu2.19+esm8
curl Ubuntu:18.04:LTS
- Версии
- 7.55.1-1ubuntu2
- 7.55.1-1ubuntu2.1
- 7.57.0-1ubuntu1
- 7.58.0-2ubuntu1
- 7.58.0-2ubuntu2
- 7.58.0-2ubuntu3
- 7.58.0-2ubuntu3.1
- 7.58.0-2ubuntu3.2
- 7.58.0-2ubuntu3.3
- 7.58.0-2ubuntu3.5
- 7.58.0-2ubuntu3.6
- 7.58.0-2ubuntu3.7
- 7.58.0-2ubuntu3.8
- 7.58.0-2ubuntu3.9
- 7.58.0-2ubuntu3.10
- 7.58.0-2ubuntu3.12
- 7.58.0-2ubuntu3.13
- 7.58.0-2ubuntu3.14
- 7.58.0-2ubuntu3.15
- 7.58.0-2ubuntu3.16
- 7.58.0-2ubuntu3.17
- 7.58.0-2ubuntu3.18
- 7.58.0-2ubuntu3.19
- 7.58.0-2ubuntu3.20
- 7.58.0-2ubuntu3.21
- 7.58.0-2ubuntu3.22
- 7.58.0-2ubuntu3.23
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.58.0-2ubuntu3.24
Обновитесь до 7.58.0-2ubuntu3.24
curl Ubuntu:20.04:LTS
- Версии
- 7.65.3-1ubuntu3
- 7.65.3-1ubuntu4
- 7.66.0-1ubuntu1
- 7.67.0-2ubuntu1
- 7.68.0-1ubuntu1
- 7.68.0-1ubuntu2
- 7.68.0-1ubuntu2.1
- 7.68.0-1ubuntu2.2
- 7.68.0-1ubuntu2.4
- 7.68.0-1ubuntu2.5
- 7.68.0-1ubuntu2.6
- 7.68.0-1ubuntu2.7
- 7.68.0-1ubuntu2.10
- 7.68.0-1ubuntu2.11
- 7.68.0-1ubuntu2.12
- 7.68.0-1ubuntu2.13
- 7.68.0-1ubuntu2.14
- 7.68.0-1ubuntu2.15
- 7.68.0-1ubuntu2.16
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.68.0-1ubuntu2.18
Обновитесь до 7.68.0-1ubuntu2.18
curl Ubuntu:22.04:LTS
- Версии
- 7.74.0-1.3ubuntu2
- 7.74.0-1.3ubuntu3
- 7.80.0-3
- 7.81.0-1
- 7.81.0-1ubuntu1.1
- 7.81.0-1ubuntu1.2
- 7.81.0-1ubuntu1.3
- 7.81.0-1ubuntu1.4
- 7.81.0-1ubuntu1.6
- 7.81.0-1ubuntu1.7
- 7.81.0-1ubuntu1.8
- Затронутые диапазоны версий
- ECOSYSTEM: < 7.81.0-1ubuntu1.10
Обновитесь до 7.81.0-1ubuntu1.10
Первоисточники
- https://hackerone.com/reports/1891474
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/36NBD5YLJXXEDZLDGNFCERWRYJQ6LAQW/
- https://security.netapp.com/advisory/ntap-20230420-0011/
- https://lists.debian.org/debian-lts-announce/2023/04/msg00025.html
- https://security.gentoo.org/glsa/202310-12
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-943925.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-27533