p PatchFirst

CVE-2023-28095

CVE-2023-28095 · OpenSIPS has vulnerability in the building the local negative replies

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.1.7 and 3.2.4 have a potential issue in `msg_translator.c:2628` which might lead to a server crash. This issue was found while fuzzing the function `build_res_buf_from_sip_req` but could not be reproduced against a running instance of OpenSIPS. This issue could not be exploited against a running instance of OpenSIPS since no public function was found to make use of this vulnerable code. Even in the case of exploitation through unknown vectors, it is highly unlikely that this issue would lead to anything other than Denial of Service. This issue has been fixed in versions 3.1.7 and 3.2.4.

CVSS 7.5 · Высокий · EPSS 1,0%

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • opensips

    Версии
    • < 3.1.7: Затронуто
    • >= 3.2.0, < 3.2.4: Затронуто

    Нет опубликованного исправления

  • opensips Ubuntu:18.04:LTS

    Версии
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →