p PatchFirst

CVE-2023-28097

CVE-2023-28097 · OpenSIPS has vulnerability in the Content-Length Parser

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, a malformed SIP message containing a large _Content-Length_ value and a specially crafted Request-URI causes a segmentation fault in OpenSIPS. This issue occurs when a large amount of shared memory using the `-m` flag was allocated to OpenSIPS, such as 10 GB of RAM. On the test system, this issue occurred when shared memory was set to `2362` or higher. This issue is fixed in versions 3.1.9 and 3.2.6. The only workaround is to guarantee that the Content-Length value of input messages is never larger than `2147483647`.

CVSS 7.5 · Высокий · EPSS 1,0%

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • opensips

    Версии
    • < 3.1.9: Затронуто
    • >= 3.2.0, < 3.2.6: Затронуто

    Нет опубликованного исправления

  • opensips Ubuntu:18.04:LTS

    Версии
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →