p PatchFirst

CVE-2023-28104

CVE-2023-28104 · silverstripe/graphql Denial of Service vulnerability

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

`silverstripe/graphql` serves Silverstripe data as GraphQL representations. In versions 4.2.2 and 4.1.1, an attacker could use a specially crafted graphql query to execute a denial of service attack against a website which has a publicly exposed graphql endpoint. This mostly affects websites with particularly large/complex graphql schemas. Users should upgrade to `silverstripe/graphql` 4.2.3 or 4.1.2 to remedy the vulnerability.

CVSS 7.5 · Высокий · EPSS 1,1% · Есть исправление

Опубликовано
Обновлено

Стек: php

Затронутые продукты и версии

  • silverstripe-graphql

    Версии
    • = 4.1.1: Затронуто
    • = 4.2.2: Затронуто

    Нет опубликованного исправления

  • silverstripe/graphql Packagist

    Версии
    • 4.1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.1.1, < 4.1.2

    Обновитесь до 4.1.2

  • silverstripe/graphql Packagist

    Версии
    • 4.2.2
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 4.2.2, < 4.2.3

    Обновитесь до 4.2.3

Первоисточники

Проверьте свой сервер →