CVE-2023-30536
CVE-2023-30536 · Insecure header validation in slim/psr7
CVSS 6.5 · Средний · EPSS 0,7% · Есть исправление
Затронуты ли вы?
- slim-psr7Нет опубликованного исправления
- php-slim-psr7 Debian 12Обновитесь до 1.6.1-1
- php-slim-psr7 Debian 13Обновитесь до 1.6.1-1
- php-slim-psr7 Debian 14Обновитесь до 1.6.1-1
- и ещё 1
Как узнать установленную версию:
dpkg-query -W -f='${source:Package} ${binary:Package} ${Version}\n' | awk '$1=="php-slim-psr7"'Бесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания slim-psr7 и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
slim/psr7 is a PSR-7 implementation for use with Slim 4. In versions prior to 1.6.1 an attacker could sneak in a newline (\n) into both the header names and values. While the specification states that \r\n\r\n is used to terminate the header list, many servers in the wild will also accept \n\n. An attacker that is able to control the header names that are passed to Slilm-Psr7 would be able to intentionally craft invalid messages, possibly causing application errors or invalid HTTP requests being sent out with an PSR-18 HTTP client. The latter might present a denial of service vector if a remote service’s web application firewall bans the application due to the receipt of malformed requests. The issue has been patched in version 1.6.1. There are no known workarounds to this issue. Users are advised to upgrade.
- Опубликовано
- Обновлено
Затронутые продукты и версии
slim-psr7
- Версии
- < 1.6.1: Затронуто
Нет опубликованного исправления
php-slim-psr7 Debian 12
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-1
Обновитесь до 1.6.1-1
php-slim-psr7 Debian 13
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-1
Обновитесь до 1.6.1-1
php-slim-psr7 Debian 14
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.1-1
Обновитесь до 1.6.1-1
slim/psr7 Packagist
- Версии
- 1.6
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 1.6, < 1.6.1
Обновитесь до 1.6.1
slim/psr7 Packagist
- Версии
- 1.5
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 1.5, < 1.5.1
Обновитесь до 1.5.1
slim/psr7 Packagist
- Версии
- 0.1.0
- 0.2.0
- 0.3.0
- 0.4.0
- 0.5.0
- 0.6
Все версии (11)
- 1.0.0
- 1.1.0
- 1.2.0
- 1.3.0
- 1.4
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.4.1
Обновитесь до 1.4.1