p PatchFirst

CVE-2023-32314

CVE-2023-32314 · Sandbox Escape

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 9.8 · Критический · EPSS 8,1% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • vm2

    Версии
    • < 3.9.18: Затронуто

    Нет опубликованного исправления

  • vm2 npm

    Затронутые диапазоны версий
    • SEMVER: < 3.9.18

    Обновитесь до 3.9.18

Первоисточники

Проверьте свой сервер →