p PatchFirst

CVE-2023-34092

CVE-2023-34092 · Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Vite provides frontend tooling. Prior to versions 2.9.16, 3.2.7, 4.0.5, 4.1.5, 4.2.3, and 4.3.9, Vite Server Options (`server.fs.deny`) can be bypassed using double forward-slash (//) allows any unauthenticated user to read file from the Vite root-path of the application including the default `fs.deny` settings (`['.env', '.env.*', '*.{crt,pem}']`). Only users explicitly exposing the Vite dev server to the network (using `--host` or `server.host` config option) are affected, and only files in the immediate Vite project root folder could be exposed. This issue is fixed in vite@4.3.9, vite@4.2.3, vite@4.1.5, vite@4.0.5, vite@3.2.7, and vite@2.9.16.

CVSS 7.5 · Высокий · EPSS 3,2% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • vite

    Версии
    • < 2.9.16: Затронуто
    • >= 3.0.2, < 3.2.7: Затронуто
    • >= 4.0.0, < 4.0.5: Затронуто
    • >= 4.1.0, < 4.1.5: Затронуто
    • >= 4.2.0, < 4.2.3: Затронуто
    • >= 4.3.0, < 4.3.9: Затронуто

    Нет опубликованного исправления

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: < 2.9.16

    Обновитесь до 2.9.16

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.2, < 3.2.7

    Обновитесь до 3.2.7

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.0.5

    Обновитесь до 4.0.5

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.1.0, < 4.1.5

    Обновитесь до 4.1.5

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.2.0, < 4.2.3

    Обновитесь до 4.2.3

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.3.0, < 4.3.9

    Обновитесь до 4.3.9

Первоисточники

Проверьте свой сервер →