CVE-2023-36814
CVE-2023-36814 · zopefoundation's Products.CMFCore vulnerable to unauthenticated denial of service and crash via unchecked use of input with Python's marshal module
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Products.CMFCore are the key framework services for the Zope Content Management Framework (CMF). The use of Python's marshal module to handle unchecked input in a public method on `PortalFolder` objects can lead to an unauthenticated denial of service and crash situation. The code in question is exposed by all portal software built on top of `Products.CMFCore`, such as Plone. All deployments are vulnerable. The code has been fixed in `Products.CMFCore` version 3.2.
CVSS 7.5 · Высокий · EPSS 0,7% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
products.cmfcore
- Версии
- < 3.2: Затронуто
Нет опубликованного исправления
products-cmfcore PyPI
- Версии
- 3.0
- 3.1
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.0, < 3.2
Обновитесь до 3.2
products-cmfcore PyPI
- Версии
- 2.1.1
- 2.1.2
- 2.1.2-beta
- 2.1.3
- 2.2.0
- 2.2.0-alpha
- 2.2.0-beta
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0-beta
- 2.3.0-beta2
- 2.3.1
- 2.4.0
- 2.4.0b1
- 2.4.0b2
- 2.4.0b3
- 2.4.0b4
- 2.4.0b5
- 2.4.0b6
- 2.4.0b7
- 2.4.0b8
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.6.0
- 2.7.0
- Затронутые диапазоны версий
- ECOSYSTEM: < 2.7.1
Обновитесь до 2.7.1
products-cmfcore PyPI
- Версии
- 2.1.1
- 2.1.2
- 2.1.2-beta
- 2.1.3
- 2.2.0
- 2.2.0-alpha
- 2.2.0-beta
- 2.2.1
- 2.2.10
- 2.2.11
- 2.2.12
- 2.2.13
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.2.6
- 2.2.7
- 2.2.8
- 2.2.9
- 2.3.0
- 2.3.0-beta
- 2.3.0-beta2
- 2.3.1
- 2.4.0
- 2.4.0b1
- 2.4.0b2
- 2.4.0b3
- 2.4.0b4
- 2.4.0b5
- 2.4.0b6
- 2.4.0b7
- 2.4.0b8
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.6
- 2.4.7
- 2.4.8
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.6.0
- 2.7.0
- 3.0
- 3.1
- 2.7.1
- Затронутые диапазоны версий
- GIT: < 40f03f43a60f28ca9485c8ef429efef729be54e5
- ECOSYSTEM: < 3.2
Обновитесь до 3.2