p PatchFirst

CVE-2023-37478

CVE-2023-37478 · pnpm incorrectly parses tar archives relative to specification

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

pnpm is a package manager. It is possible to construct a tarball that, when installed via npm or parsed by the registry is safe, but when installed via pnpm is malicious, due to how pnpm parses tar archives. This can result in a package that appears safe on the npm registry or when installed via npm being replaced with a compromised or malicious version when installed via pnpm. This issue has been patched in version(s) 7.33.4 and 8.6.8.

CVSS 7.5 · Высокий · EPSS 1,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • pnpm

    Версии
    • < 7.33.4: Затронуто
    • >= 8.0.0, < 8.6.8: Затронуто

    Нет опубликованного исправления

  • pnpm npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/exe npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/linux-arm64 npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/linux-x64 npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/linuxstatic-arm64 npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/macos-arm64 npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/macos-x64 npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/win-x64 npm

    Затронутые диапазоны версий
    • SEMVER: < 7.33.4

    Обновитесь до 7.33.4

  • @pnpm/cafs npm

    Затронутые диапазоны версий
    • SEMVER: < 7.0.5

    Обновитесь до 7.0.5

  • pnpm npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/exe npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/linux-arm64 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/linux-x64 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/linuxstatic-arm64 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/macos-arm64 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/macos-x64 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

  • @pnpm/win-x64 npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.6.8

    Обновитесь до 8.6.8

Первоисточники

Проверьте свой сервер →