CVE-2023-37924
CVE-2023-37924 · Apache Submarine: SQL injection from unauthorized login
CVSS 9.8 · Критический · EPSS 7,2% · Есть исправление
Затронуты ли вы?
- apache submarineОбновитесь до 0.8.0
- apache-submarine PyPIОбновитесь до 0.8.0
Как узнать установленную версию:
pip show apache-submarineБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания apache submarine и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Apache Software Foundation Apache Submarine has an SQL injection vulnerability when a user logs in. This issue can result in unauthorized login. Now we have fixed this issue and now user must have the correct login to access workbench. This issue affects Apache Submarine: from 0.7.0 before 0.8.0. We recommend that all submarine users with 0.7.0 upgrade to 0.8.0, which not only fixes the issue, supports the oidc authentication mode, but also removes the case of unauthenticated logins. If using the version lower than 0.8.0 and not want to upgrade, you can try cherry-pick PR https://github.com/apache/submarine/pull/1037 https://github.com/apache/submarine/pull/1054 and rebuild the submarine-server image to fix this.
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache submarine
- Версии
- ≥ 0.7.0, < 0.8.0: Затронуто (semver)
Обновитесь до 0.8.0
apache-submarine PyPI
- Версии
- 0.7.0
- 0.8.0.dev0
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 0.7.0, < 0.8.0
Обновитесь до 0.8.0