p PatchFirst

CVE-2023-37941

CVE-2023-37941 · Apache Superset: Metadata db write access can lead to remote code execution

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

If an attacker gains write access to the Apache Superset metadata database, they could persist a specifically crafted Python object that may lead to remote code execution on Superset's web backend. The Superset metadata db is an 'internal' component that is typically only accessible directly by the system administrator and the superset process itself. Gaining access to that database should be difficult and require significant privileges. This vulnerability impacts Apache Superset versions 1.5.0 up to and including 2.1.0. Users are recommended to upgrade to version 2.1.1 or later.

CVSS 6.6 · Средний · EPSS 35,5% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • apache superset

    Версии
    • ≥ 1.5.0, ≤ 2.1.0: Затронуто (semver)

    Нет опубликованного исправления

  • apache-superset PyPI

    Версии
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.5.0, < 2.1.1

    Обновитесь до 2.1.1

Первоисточники

Проверьте свой сервер →